Bug 799788 - ksvalidator report incorrect info (output %% instead of % )
ksvalidator report incorrect info (output %% instead of % )
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pykickstart (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 21:50 EST by Xiaoqing Wei
Modified: 2012-03-05 09:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 09:44:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoqing Wei 2012-03-04 21:50:51 EST
Description of problem:
ksvalidator outputs incorrect info

Version-Release number of selected component (if applicable):
pykickstart-1.99.4-1.el7.noarch
Section does not end with %%end.

How reproducible:
100%

Steps to Reproduce:
1.
#tail -2  rhel7-ks.cfg 
echo "co:2345:respawn:/sbin/agetty 115200 ttyS0" >> /etc/inittab
#%end
 
2. ksvalidator rhel7-ks.cfg 
The following problem occurred on line 105 of the kickstart file:
Section does not end with %%end.

                          ^^^^^
3.
  
Actual results:

output %% instead of %
Expected results:

should report correctly.
Additional info:

# tail -2  rhel7-ks.cfg 
echo "co:2345:respawn:/sbin/agetty 115200 ttyS0" >> /etc/inittab
%end
# ksvalidator rhel7-ks.cfg 

# echo $?
0
Comment 1 Chris Lumens 2012-03-05 09:44:35 EST
I am unable to reproduce this problem with pykickstart-1.99.7, which is the version currently in Fedora and that I assume will get pulled into RHEL7 when we do rebasing.

Note You need to log in before you can comment on or make changes to this bug.