Bug 799814 - No validation for "aeolus-configure" command
No validation for "aeolus-configure" command
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-all (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Mike Orazi
Rehana
:
: 809349 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 01:19 EST by Rehana
Modified: 2012-12-04 09:57 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When running the 'aeolus-configure' command with incorrect options, no error message or usage information was displayed. This bug fix adds basic validations to aeolus-configure, so that a message of "Invalid options supplied" is displayed along with usage options.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:57:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (7.26 KB, application/octet-stream)
2012-03-05 01:19 EST, Rehana
no flags Details

  None (edit)
Description Rehana 2012-03-05 01:19:04 EST
Created attachment 567478 [details]
log

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Installed aeolus 
2.To configure provider accounts, i have given the command 
   "aeolus-configure vsphere_configure,rhevm_configure,ec2"
  
Actual results:

The command did not give any error in the CLI , and displayed the log (PFA.Log),but the providers were not added in the "Conductor"

Expected results:
The command should validate its parameters in CLI.

Additional info:
[root@hp-dl320g5-01 nodes]# rpm -qa | grep aeolus
aeolus-conductor-0.8.0-39.el6.noarch
aeolus-configure-2.5.0-16.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-all-0.8.0-39.el6.noarch
rubygem-aeolus-image-0.3.0-11.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
aeolus-conductor-doc-0.8.0-39.el6.noarch
Comment 1 Maros Zatko 2012-05-08 11:41:47 EDT
in git

commit 92b67a1608f98b87ba4b61de238cd8f3d169a87d
Author: Maros Zatko <mzatko@redhat.com>
Date:   Mon Apr 23 15:53:30 2012 +0200

    BZ799814: added basic validations for aeolus-configure
Comment 2 Maros Zatko 2012-05-08 11:51:03 EDT
*** Bug 809349 has been marked as a duplicate of this bug. ***
Comment 5 pushpesh sharma 2012-09-20 05:23:01 EDT
Better validation for aeolus-configure command.Verified on:-

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch


[root@dhcp201-113 ~]# aeolus-configure mock,ec2
Invalid options supplied.

USAGE:
aeolus-configure [-d|--debug] [-h|--help] [-v|--verbose] [-p|--profile]

OPTIONS:
   -h | --help       Show this message.
   -d | --debug      Debug logging mode.
   -v | --verbose    Verbose logging mode.
                     Note that you can only set one of the previous two options per run. If both are set,
                     the last one passed in will be honored.
   -p | --profile    Name of profile to use. A comma separated list can be used to specify multiple profiles.
   -s | --skip-missing  Skip missing profiles provided by -p option.
[root@dhcp201-113 ~]# aeolus-configure -s mock,ec2
Invalid options supplied.

USAGE:
aeolus-configure [-d|--debug] [-h|--help] [-v|--verbose] [-p|--profile]

OPTIONS:
   -h | --help       Show this message.
   -d | --debug      Debug logging mode.
   -v | --verbose    Verbose logging mode.
                     Note that you can only set one of the previous two options per run. If both are set,
                     the last one passed in will be honored.
   -p | --profile    Name of profile to use. A comma separated list can be used to specify multiple profiles.
   -s | --skip-missing  Skip missing profiles provided by -p option.
[root@dhcp201-113 ~]# aeolus-configure -p mock ec2
Invalid options supplied.

USAGE:
aeolus-configure [-d|--debug] [-h|--help] [-v|--verbose] [-p|--profile]

OPTIONS:
   -h | --help       Show this message.
   -d | --debug      Debug logging mode.
   -v | --verbose    Verbose logging mode.
                     Note that you can only set one of the previous two options per run. If both are set,
                     the last one passed in will be honored.
   -p | --profile    Name of profile to use. A comma separated list can be used to specify multiple profiles.
   -s | --skip-missing  Skip missing profiles provided by -p option.
Comment 8 errata-xmlrpc 2012-12-04 09:57:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.