Bug 799864 - [virtio-win]user cannot distinguish the difference between viostor and vioscsi because of listing the two drivers together at the same time in Device Manager
[virtio-win]user cannot distinguish the difference between viostor and vioscs...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 05:02 EST by Min Deng
Modified: 2013-02-28 07:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 07:59:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unfriendly dialog (80.67 KB, image/png)
2012-03-05 05:02 EST, Min Deng
no flags Details

  None (edit)
Description Min Deng 2012-03-05 05:02:35 EST
Created attachment 567544 [details]
unfriendly dialog

Description of problem:
  Now,we support viostor and vioscsi together.But while user pick up one to install,the two drivers are listed together from Device Manager.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-23
How reproducible:
Always,
Steps to Reproduce:
1.Boot up guest with the following CLI 
  /usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic,family=0xf -usb -device usb-tablet -drive file=win7-32-scsi.raw,format=raw,if=none,id=ide0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=ide0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:13:29:4c:37:a8 -uuid 5da59795-745b-4f9c-9b20-e0463d38eaaa -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-blk-scsi,server,nowait -mon chardev=111a,mode=readline -vnc :1 -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -device virtio-scsi-pci,id=scsi1 -drive file=disk1.raw,if=none,format=raw,cache=none,id=drive-virtio-data1,werror=stop,rerror=stop -device scsi-hd,bus=scsi1.0,id=virtio-data1,drive=drive-virtio-data1 -device virtio-scsi-pci,id=scsi2 -drive file=disk2.raw,if=none,cache=none,format=raw,id=drive-virtio-data2,werror=stop,rerror=stop -device scsi-hd,bus=scsi2.0,id=virtio-data2,drive=drive-virtio-data2 -device virtio-scsi-pci,id=scsi3 -drive file=disk3.raw,cache=none,if=none,format=raw,id=drive-virtio-data3,werror=stop,rerror=stop -device scsi-hd,bus=scsi3.0,id=virtio-data3,drive=drive-virtio-data3 -device virtio-scsi-pci,id=scsi4 -drive file=disk4.raw,if=none,format=raw,cache=none,id=drive-virtio-data4,werror=stop,rerror=stop -device scsi-hd,bus=scsi4.0,id=virtio-data4,drive=drive-virtio-data4 -bios /root/bios.bin
 
2.install the vioscsi
  Open device manager -> select the needed device -> choose Update driver -> browser computer for driver software ->Let me pick up ...->Located to the driver folder and choose vioscsi 

  
Actual results:
1.while selecting vioscsi to install,the viostor driver also be listed in the table.As QE,I can distinguished them through the different version number.It is a bit difficult for customer because they have no any idea about these number.
  If possible,we had better list one.

2.During the driver's installation,there is an unfriendly dialog pop up.The issue can be reproduced on windows 2008 32/64 and windows 7 32/64 guest.Please see attachment.
3.The version number also be highlighted here.
  The vioscsi's version is 15.57.51.656 now.Could this be final version number?

Expected results:
1.we had better show one driver in case of confusing.
2.whether it is necessary for the dialog pop up or not --attachment
3.Maybe,the version should be changed to a correct one for rhel6.3 
 (Just suggestion)

 Any issues please let me know,welcome to correct me if any mistakes as well.
Thanks.

Additional info:
Comment 2 Ronen Hod 2012-03-13 13:50:03 EDT
Since virtio-scsi was postponed to 6.4. Also postponing this bug.
Comment 3 Vadim Rozenfeld 2012-06-19 14:25:46 EDT
Hi Min,
please check if it looks better with the driver from build 29.

http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/29/win/virtio-win-prewhql-0.1.zip
Comment 4 Min Deng 2012-06-20 03:05:39 EDT
Hi Vadim,
   Re-tested the bug on windows 7 32/64 and windows 2008.One driver is listed in Device Manager if user want to install vioscsi driver now.User can finish install the driver without any errors.
  so the original issue should be fixed.By the way,now,the driver name is changed to "redhat virtio scsi pass-through controller".
  Thanks for your work.

Best Regards,
Min
Comment 5 Mike Cao 2012-06-20 03:16:21 EDT
Based on comment #4 ,this issue has been fixed already .Move status to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.