Bug 799869 - Failed to start virt-p2v-server on remote host:Warning: Use of "shift" without parentheses is ambiguous at /usr/bin/virt-p2v-server line 402.
Failed to start virt-p2v-server on remote host:Warning: Use of "shift" withou...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.3
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 05:18 EST by tingting zheng
Modified: 2012-06-20 08:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: virt-v2v-0.8.7-3.el6
Doc Type: Bug Fix
Doc Text:
No documentation required. This was never in a RHEL release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2012-03-05 05:18:11 EST
Description of Problem:
When using virt-p2v to convert a physical host,it failed to start virt-p2v-server on remote host.
Also when start virt-p2v-server,there is warning: Use of "shift" without parentheses is ambiguous at /usr/bin/virt-p2v-server line 402.

Version-Release number of selected component:
virt-v2v-0.8.7-1.el6.x86_64
rubygem-virt-p2v-0.8.6-1.el6


How reproducible:
Always

Step to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Plug in USB,boot the Live CD with USB
#livecd-iso-to-disk --format VirtP2V_0.8.6-1.iso  /dev/sdb 

4.Boot from USB,input the ip and password of conversion server,when click connect,error occured:Failed to start virt-p2v-server on remote host


Actual Results:
When connect the conversion server,there is error:Failed to start virt-p2v-server on remote host


Expected Results:
It should connect the conversion server successfully.

Additional info:
When start virt-p2v-server on conversion server manully,there is warning:
Warning: Use of "shift" without parentheses is ambiguous at /usr/bin/virt-p2v-server line 402.
VIRT_P2V_SERVER 0.8.7
Comment 4 yuping zhang 2012-03-09 02:31:25 EST
I can reproduce this issue with virt-v2v-0.8.7-1.el6.x86_64
# /usr/bin/virt-p2v-server 
Warning: Use of "shift" without parentheses is ambiguous at /usr/bin/virt-p2v-server line 402.
VIRT_P2V_SERVER 0.8.7
^C

Verified this issue with:
virt-v2v-0.8.7-4.el6.x86_64
# rpm -Uvh virt-v2v-0.8.7-4.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:virt-v2v               ########################################### [100%]
# /usr/bin/virt-p2v-server 
VIRT_P2V_SERVER 0.8.7

So change the bug status to VERIFIED.
Comment 5 Matthew Booth 2012-04-11 10:07:13 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation required.

This was never in a RHEL release.
Comment 7 errata-xmlrpc 2012-06-20 08:42:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0788.html

Note You need to log in before you can comment on or make changes to this bug.