Bug 799897 - v7 server starts/stops returns 1
v7 server starts/stops returns 1
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Petr Beňas
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-03-05 06:18 EST by Petr Beňas
Modified: 2015-01-04 18:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network test patch to fix start/stop server return values (2.08 KB, patch)
2012-03-15 15:18 EDT, Greg Nichols
no flags Details | Diff
kdump patch to fix start/stop server return values (1.77 KB, patch)
2012-03-15 15:19 EDT, Greg Nichols
no flags Details | Diff
hardware test patch fixing server start/stop return values (721 bytes, patch)
2012-03-15 15:21 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Petr Beňas 2012-03-05 06:18:35 EST
Description of problem:
v7 server wrong exit codes and errors when v7-server not installed

Version-Release number of selected component (if applicable):
v7-1.5-7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
v7 server start
echo $?
v7 server stop
echo $?
  
Actual results:
if v7-server is installed, no error reported, only exit code is 1
[root@hp-xw6400-02 ~]# v7 server start
v7-server-1.5-7.el6.noarch
network test server start:
Warning: SELinux is in enforcing mode - it must be set to "permissive" for certification testing.
Starting lmbench services... done.
Starting httpd:                                            [  OK  ]

kdump test server start:
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]

Starting v7 daemon
[root@hp-xw6400-02 ~]# echo $?
1
[root@hp-xw6400-02 ~]# v7 server stop
v7-server-1.5-7.el6.noarch
network test server stop:
Stopping lmbench services... done.
Stopping httpd:                                            [  OK  ]

kdump test server stop:
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]

Stopping v7 daemon
[root@hp-xw6400-02 ~]# echo $?
1

if v7-server not installed, server seems to start/stop, but following errors reported
package v7-server is not installed
Error: the v7-server package is not installed.
Would you like to install it now? (y|n) n
response: n
network test server start:
Warning: SELinux is in enforcing mode - it must be set to "permissive" for certification testing.
Starting lmbench services... done.
Starting httpd:                                            [  OK  ]

kdump test server start:
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]

The v7 server daemon is already started
[root@hp-xw6400-02 ~]# v7 server stop
package v7-server is not installed
Error: the v7-server package is not installed.
Would you like to install it now? (y|n) n
response: n
network test server stop:
Stopping lmbench services... done.
Stopping httpd:                                            [  OK  ]

kdump test server stop:
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]

Stopping v7 daemon
Error: could not stop daemon:
"kill 2489" has output on stderr


Expected results:
exit code is 0 on successful start/stop

Additional info:
Is desired to offer user installation on server stop?
Comment 1 Greg Nichols 2012-03-15 15:18:56 EDT
Created attachment 570413 [details]
network test patch to fix start/stop server return values
Comment 2 Greg Nichols 2012-03-15 15:19:59 EDT
Created attachment 570414 [details]
kdump patch to fix start/stop server return values
Comment 3 Greg Nichols 2012-03-15 15:21:28 EDT
Created attachment 570416 [details]
hardware test patch fixing server start/stop return values
Comment 7 Petr Beňas 2012-03-29 04:36:36 EDT
Reproduced in v7-1.5-8.el6.noarch and verified in v7-1.5-9.el6.noarch.
Comment 8 Caspar Zhang 2012-06-04 03:55:00 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 10 errata-xmlrpc 2012-06-05 17:37:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.