Bug 799930 - lockf: F_TEST always fails on gNFS
lockf: F_TEST always fails on gNFS
Status: CLOSED DUPLICATE of bug 799244
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 07:51 EST by Sachidananda Urs
Modified: 2015-12-01 11:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 08:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fcntl version (717 bytes, text/x-csrc)
2012-03-05 08:14 EST, Sachidananda Urs
no flags Details

  None (edit)
Description Sachidananda Urs 2012-03-05 07:51:02 EST
Description of problem:

lockf(int filedes, int function, off_t size) always fails on gNFS (works on kernel NFS and FUSE though).

Version-Release number of selected component (if applicable):

3.3.0qa25

How reproducible:

Always.

Steps to Reproduce:

Program attached.
  
Actual results:

lockf fails.

Expected results:

lockf should pass.
Comment 1 Sachidananda Urs 2012-03-05 08:14:42 EST
Created attachment 567606 [details]
fcntl version
Comment 2 Krishna Srinivas 2012-03-08 08:36:26 EST
This behavior was seen as kernel lockd was also running. We can close this bug. We have to document that glusterfs-NLM can not run when lockd is also running.
Comment 3 Amar Tumballi 2012-03-12 05:46:26 EDT
please update these bugs w.r.to 3.3.0qa27, need to work on it as per target milestone set.
Comment 4 Sachidananda Urs 2012-03-12 08:07:51 EDT
Works when there is no kernel NFS mount on the machine.

However, this needs to be documented. Kris, can we keep this till documentation is in place?
Comment 5 Amar Tumballi 2012-03-13 03:02:51 EDT
We can document this behavior. But we need to fix the root cause of kernel NFSv4 being present failing our NLM.
Comment 6 Vidya Sakar 2012-03-20 08:09:13 EDT
Documented in the known issues section for beta1. To be investigated for beta2.
Comment 7 Krishna Srinivas 2012-04-04 08:31:47 EDT

*** This bug has been marked as a duplicate of bug 799244 ***

Note You need to log in before you can comment on or make changes to this bug.