Bug 799967 - Quick search didn't return any bugs but there are 2
Quick search didn't return any bugs but there are 2
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.6
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 09:14 EST by Alexander Todorov
Modified: 2014-10-12 18:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 22:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 742683 None None None Never

  None (edit)
Description Alexander Todorov 2012-03-05 09:14:18 EST
Description of problem:

Search term "group qpidd does not exist" or this url:
https://bugzilla.redhat.com/buglist.cgi?quicksearch=group+qpidd+does+not+exist

returns no bugs. 

But 799877 and 798622  contain the text I'm searching for:

23:59:31 Installing psmisc-22.14-1.el7.ppc64
23:59:31 Installing matahari-core-0.5.0-1.el7.ppc64
/var/tmp/rpm-tmp.qvObvA: line 1: groupadd: command not found
warning: group qpidd does not exist - using root



Searching for already reported bugs doesn't work in this case.
Comment 1 Simon Green 2012-04-04 01:53:36 EDT
Definitely looks like a problem for bug 798622.

Bug 799877 won't be picked up because your search does not include bugs with the status of CLOSED.
Comment 2 Simon Green 2012-04-05 01:15:05 EDT
Well I found out why it doesn't work. MySQL has a list of 'stop words' that aren't used in fulltext search. If you use any of these words (in your case, 'does') then the query will fail.

I'm going to raise the issue upstream, since it will affect their Bugzilla too.

http://dev.mysql.com/doc/refman/5.5/en/fulltext-stopwords.html

  -- simon
Comment 3 Simon Green 2012-04-05 07:45:48 EDT
I have filed this bug - with a patch - upstream.
https://bugzilla.mozilla.org/show_bug.cgi?id=742683

If they do not accept it, we will have to carry it locally. I'll keep this bug updated.

  -- simon
Comment 4 Simon Green 2012-05-30 22:06:16 EDT
Upstream marked it as WORKSFORME, so I'm marking this as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.