Bug 799988 - security policy: root password needed when it shouldn't be
security policy: root password needed when it shouldn't be
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cups-pk-helper (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
http://ponzo.net/PolKit-printer/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 09:51 EST by Scott Doty
Modified: 2013-02-13 14:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 14:05:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Doty 2012-03-05 09:51:44 EST
Description of problem:

https://bugs.freedesktop.org/show_bug.cgi?id=46943

Upstream, they say this is a problem with Fedora, not them.

Version-Release number of selected component (if applicable):

cups-pk-helper-0.1.3-3.fc16.x86_64

How reproducible:

Try adding a networked printer.  Requires root password, which unnecessarily exposes root password to interception and compromise.

Since users, in almost all cases, can contact network printers on their own, requiring _any_ password for a user to add a printer for their own use does nothing but needlessly expose passwords to interception and compromise.

Additional info:

Screenshots:

http://ponzo.net/PolKit-printer/
Comment 1 Tomas Mraz 2012-03-05 10:51:34 EST
Well as long as the printer is set up system-wide and the machine is a multi-user machine this is still a security problem to not require any sysadmin authentication. As you could add silently a printer for other users that would intercept the documents that they are printing.

So I'd say definitely no need to ask for a password if the printer is set just for the user that asks for the action, otherwise some kind of authentication is surely needed being it root or wheel group user password.
Comment 2 Scott Doty 2012-03-05 11:03:38 EST
Agreed, Tomas -- though as you can see from the screenshots, I was asked for both my (wheel) user password, as well as root password at the very last.

Also, this is reported here:

   https://fedorahosted.org/fesco/ticket/816
Comment 3 Tomas Mraz 2012-03-05 11:11:49 EST
Yes, there is no dispute that the current process is really suboptimal.
Comment 4 Rex Dieter 2012-03-05 15:46:00 EST
I'm not able to reproduce your claim that a root password is required.

I ran system-config-printer, tried to add a network printer, was prompted for my own admin (wheel group) password by polkit 3 times, but never saw the forth one you mention.

Am I missing something?
Comment 5 Rex Dieter 2012-03-05 15:48:58 EST
Someone else on irc just mentioned seeing the root dialog too, so sounds like I am indeed doing something different or wrong.
Comment 6 Marek Kašík 2012-03-06 06:13:59 EST
Hi,

I agree with Tomas here. As long as we set the printer system-wide we need to require sysadmin authentication. Also, CUPS needs root privileges when adding a printer using lpadmin.

Regarding the wheel group, it asks you for your user (wheel) password if you are in the group. The last dialog is a bug in cups-pk-helper or system-config-printer, you shouldn't see it when adding a printer. It is system-config-printer's fail-safe dialog for situation when communication with cups-pk-helper failed (or for authentication of jobs requiring authentication).

Does the dialog show name of an operation in its title? Something like "Authentication (adding printer LaserJet)"?

Regards

Marek
Comment 7 Fedora End Of Life 2013-01-16 10:54:51 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Fedora End Of Life 2013-02-13 14:05:52 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.