Bug 799998 - netfs RA won't mount NFS export if already mounted
netfs RA won't mount NFS export if already mounted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: 6.3
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 10:19 EST by Robert Rati
Modified: 2012-06-20 10:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: resource-agents-3.9.2-11.el6
Doc Type: Bug Fix
Doc Text:
Cause: netfs script doesn't check if file system is a network file system before denying multiple mounts Consequence: you can't mount network filesystems twice Fix: netfs script now verifies if file system is a network filesystem and if it is, it allows multiple mounts Result: Multiple network file system mounts of the same filesystem are allowed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2012-03-05 10:19:24 EST
Description of problem:
I manually mounted a NFS export at a different mountpoint (/mnt/condor-qsjs) than was in the cluster.conf, and for a different reason, and the netfs RA refused to mount the export when it tried to start the cluster service.  The logs showed:

[netfs] Device 192.168.122.176:/opt/condor is mounted on /mnt/condor-qsjs instead of /mnt/condor-schedd1
unmounting /mnt/condor-schedd1
[netfs] Calling 'umount -f /mnt/condor-schedd1'
[netfs] Sending SIGTERM to processes on /mnt/condor-schedd1


Version-Release number of selected component (if applicable):
resource-agents-3.9.2-7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 7 Chris Feist 2012-04-30 18:22:04 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: netfs script doesn't check if file system is a network file system before denying multiple mounts

Consequence: you can't mount network filesystems twice

Fix: netfs script now verifies if file system is a network filesystem and if it is, it allows multiple mounts

Result: Multiple network file system mounts of the same filesystem are allowed
Comment 9 errata-xmlrpc 2012-06-20 10:41:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0947.html

Note You need to log in before you can comment on or make changes to this bug.