Bug 800002 - FTBFS: rubygem-curb-0.7.10-1.el6
FTBFS: rubygem-curb-0.7.10-1.el6
Status: CLOSED NOTABUG
Product: CloudForms Common
Classification: Red Hat
Component: rubygem-curb (Show other bugs)
1.0.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Linabery
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 10:31 EST by John Eckersberg
Modified: 2012-04-25 15:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 15:44:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2012-03-05 10:31:56 EST
rubygem-curb fails to rebuild from source.  See build failure at https://brewweb.devel.redhat.com/taskinfo?taskID=4104028 for details.
Comment 3 Ken Dreyer 2012-04-06 19:31:42 EDT
I ran across this earlier when trying to build this package on EL6 (potentially for EPEL.) The error in mock:

Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/rubygem-curb-0.7.10-4.el6.i386
RPM build errors:
error: Installed (but unpackaged) file(s) found:
   /usr/lib/ruby/gems/1.8/gems/curb-0.7.10/.require_paths
    Installed (but unpackaged) file(s) found:
   /usr/lib/ruby/gems/1.8/gems/curb-0.7.10/.require_paths

It looks like the Fedora author originally excluded these files, but then dropped the exclusion in commit b650be2683.
Comment 4 Jay Turner 2012-04-25 15:44:25 EDT
rubygem-curb confirmed to be building correctly on x86_64 (the only arch where it is shipped with CloudForms) so closing this out.  I suspect the issue was simply missing buildrequires in TPS as those needed to be installed by-hand as they are themselves part of the CloudForms release.

Note You need to log in before you can comment on or make changes to this bug.