Bug 800010 - FTBFS: gtk-vnc-0.4.2-4.el6
FTBFS: gtk-vnc-0.4.2-4.el6
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: gtk-vnc (Show other bugs)
1.0.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: John Eckersberg
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 10:35 EST by John Eckersberg
Modified: 2012-05-15 15:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 15:55:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2012-03-05 10:35:51 EST
gtk-vnc fails to rebuild from source.  See build failure at https://brewweb.devel.redhat.com/taskinfo?taskID=4107708 for details.
Comment 1 John Eckersberg 2012-03-06 16:42:44 EST
Missing build dependency:

DEBUG util.py:256:  No Package Found for perl(Text::CSV)
Comment 2 jrd 2012-03-12 12:16:42 EDT
Not sure why this would belong to me.  Bouncing back for reassignment.
Comment 3 Mike Orazi 2012-03-14 18:16:40 EDT
Oz is brining this in and we thought you would be the best person to help locate the real owner and assign accordingly.
Comment 4 Ian McLeod 2012-03-15 16:34:16 EDT
This built successfully in Brew almost a year ago:

https://brewweb.devel.redhat.com/buildinfo?buildID=161717

The log indicates that perl-Text-CSV was successfully installed during the build process from the "build" repo.

http://download.devel.redhat.com/brewroot/packages/gtk-vnc/0.4.2/4.el6/data/logs/x86_64/root.log


DEBUG util.py:280:  Executing command: /usr/bin/yum --installroot /var/lib/mock/ce-rhel-6-build-961907-301032/root/  install  'zlib-devel' 'pygtk2-devel' 'intltool' 'gnutls-devel' 'gtk2-devel >= 2.14' 'python-devel' 'cyrus-sasl-devel' 'perl(Text::CSV)'
DEBUG util.py:256:  ================================================================================
DEBUG util.py:256:   Package                    Arch       Version                  Repository
DEBUG util.py:256:                                                                             Size
DEBUG util.py:256:  ================================================================================
DEBUG util.py:256:  Installing:
DEBUG util.py:256:   cyrus-sasl-devel           x86_64     2.1.23-8.el6             build     301 k
DEBUG util.py:256:   gnutls-devel               x86_64     2.8.5-4.el6              build     1.1 M
DEBUG util.py:256:   gtk2-devel                 x86_64     2.18.9-4.el6             build     2.4 M
DEBUG util.py:256:   intltool                   noarch     0.41.0-1.1.el6           build      57 k
DEBUG util.py:256:   perl-Text-CSV              noarch     1.16-2.el6               build      47 k
DEBUG util.py:256:   pygtk2-devel               x86_64     2.16.0-3.el6             build     140 k
DEBUG util.py:256:   python-devel               x86_64     2.6.5-3.el6_0.2          build     159 k
DEBUG util.py:256:   zlib-devel                 x86_64     1.2.3-25.el6             build      42 k

I'm not sure why it's now unable to be sourced by the build system.

John,

Any pointers or thoughts?
Comment 5 John Eckersberg 2012-03-15 16:49:41 EDT
Somewhere along the way it's been untagged from brew.  I've retagged the above build (perl-Text-CSV-1.16-2.el6) back into ce-rhel-6-candidate.  If this fixes the build, then we'll just need to make sure we (1) get perl-Text-CSV added as a bugzilla component and (2) into an erratum for cloudforms-1.0 (I can take care of of those parts)
Comment 7 wes hayutin 2012-03-30 14:58:00 EDT
assigning to rehana
Comment 8 wes hayutin 2012-04-03 09:59:24 EDT
This passes.. https://errata.devel.redhat.com/errata/rpmdiff.cgi?id=12866
Comment 9 errata-xmlrpc 2012-05-15 15:55:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0590.html

Note You need to log in before you can comment on or make changes to this bug.