Bug 800055 - Some authorized_keys files are HUGE
Some authorized_keys files are HUGE
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 11:52 EST by Thomas Wiest
Modified: 2015-05-14 18:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 14:22:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Wiest 2012-03-05 11:52:36 EST
Description of problem:
Some apps' authorized keys files are HUGE in STG (like 75M). The file has the key and then tons of blank lines and then the key again a few times.

This causes problems as cdk-authorized-ssh-key-remove bloats to multiple gigs of memory when trying to work with these files (which eventually runs the machine out of memory, which then causes our monitoring to reboot the instance.


Version-Release number of selected component (if applicable):
rhc-node-0.87.14-1.el6_2.x86_64


How reproducible:
Unsure

Steps to Reproduce:
1. Unsure how to get the keys into this state.

  
Actual results:
Huge authorized_keys files

Expected results:
The authorized_keys files should only be as large as the number of keys in them.
Comment 1 Krishna Raman 2012-03-05 12:02:20 EST
cdk-authorized-ssh-key-remove was doubling the number of newlines every time it was run causing file sizes to grow.
Comment 2 Xiaoli Tian 2012-03-06 05:01:07 EST
(In reply to comment #1)
> cdk-authorized-ssh-key-remove was doubling the number of newlines every time it
> was run causing file sizes to grow.

Hi,Thomas

For user can not access the authorized_keys files on stage,and QE can not access stage server as well, could not find a better way to verify it, could you please help to verify this on stage,QE will verify this on devenv once there's new build comes.

Thanks
Comment 3 Meng Bo 2012-03-08 04:11:04 EST
verified on devenv_1654, issue cannot be reproduced.

Since I don't know the exact repro steps, I tried to add and remove ssh keys for many times. And didn't hit this issue.

mark as verified.
Comment 4 Thomas Wiest 2012-03-08 12:52:32 EST
I think that's reasonable.

Unfortunately we don't have repro steps either, we just noticed the problem in STG and told kraman about it and he fixed it.

Note You need to log in before you can comment on or make changes to this bug.