Bug 800056 - beakerlib from RHEL7 doesn't provide rlIsRHEL function
beakerlib from RHEL7 doesn't provide rlIsRHEL function
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: beakerlib (Show other bugs)
rawhide
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Petr Muller
Fedora Extras Quality Assurance
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 11:52 EST by Karel Srot
Modified: 2016-09-19 22:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 12:08:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2012-03-05 11:52:59 EST
Description of problem:

this is the reason why several tests are failing on rhel7


[root@nec-em24-3 beakerlib]# rpm -q beakerlib
beakerlib-1.3-5.el7.noarch
[root@nec-em24-3 beakerlib]# grep 'rlIsRHEL(' /usr/share/beakerlib/*
[root@nec-em24-3 beakerlib]# ls /usr/share/beakerlib/testing.sh
/usr/share/beakerlib/testing.sh


while on rhel6

[ksrot@dhcp-30-102 ~]$ rpm -q beakerlib
beakerlib-1.3-7.el6.noarch
[ksrot@dhcp-30-102 ~]$ grep 'rlIsRHEL(' /usr/share/beakerlib/*
/usr/share/beakerlib/testing.sh:rlIsRHEL(){
Comment 1 Karel Srot 2012-03-05 12:08:47 EST
I can see this is already fixed in beakerlib-1.4-1.el7. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.