Bug 800118 - X fails with any kernel while trying to use the nVidia driver
X fails with any kernel while trying to use the nVidia driver
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 14:21 EST by kevin martin
Modified: 2012-03-05 18:43 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 17:05:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (89.88 KB, text/plain)
2012-03-05 14:21 EST, kevin martin
no flags Details

  None (edit)
Description kevin martin 2012-03-05 14:21:55 EST
Created attachment 915422 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 kevin martin 2012-03-05 16:02:07 EST
Also see this from time to time:


 kernel:[ 7164.152638] BUG: spinlock lockup on CPU#2, X/2250

 kernel:[ 7164.152646]  lock: ffffffffa272bdd8, .magic: dead4ead, .owner: <none>/-1, .owner_cpu: -1
Comment 2 Adam Jackson 2012-03-05 17:05:38 EST
[  602.338974]  [<ffffffffa23554c1>] ? nv_kern_open+0x91/0x830 [nvidia]
[  602.339035]  [<ffffffffa23554c1>] ? nv_kern_open+0x91/0x830 [nvidia]

Looks like a bug in nvidia's kernel code to me, which means it's not something we can fix.  Sorry.  You'll have to follow up with nvidia on this.
Comment 3 kevin martin 2012-03-05 18:43:02 EST
Hmm, funny, how did I know that would be the response.  Strange how the nvidia driver(s) have been working ok up until the update I did this weekend and then, suddenly, X stops working but it's nvidia's fault (even though nothing changed on their side).  I've fallen back to using nouveau again at this point (although I still have to use noaccel on the vmlinuz line in my grub2.cfg to get the nouveau driver to work).  Sigh....

Note You need to log in before you can comment on or make changes to this bug.