Bug 80016 - Absoft can't find errno!
Absoft can't find errno!
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 80017 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-18 14:49 EST by Sammy
Modified: 2016-11-24 10:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-18 15:02:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2002-12-18 14:49:20 EST
The Asbsoft Fortran 95 compiler for linux is giving an error which started 
recently in rawhide. Which library is errno in now? Thanks 
 
================================================= 
f95 -o ../../run/dws.exe grid_def_2d_cyl_v32.o   spinor_def_2d_cyl_v24.o 
special_functions_v12.o  dws_v35.o  ../spline90/spline90.a /usr/lib/lapack95_intel.a 
/usr/lib/libmkl_lapack.a /usr/lib/libmkl_p4.a -lf2c -lm -lpthread 
/usr/absoft/lib/libfio.a(ioerr.o)(.text+0x233): In function `_ioerr': 
: `sys_errlist' is deprecated; use `strerror' or `strerror_r' instead 
/usr/absoft/lib/libfio.a(open.o)(.text+0xdbd): In function `_f_open3': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0xf9): In function `_getfile': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x141): In function `_releasefile': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x16c): In function `_releasefile': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x1dc): In function `_f_seek': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x223): more undefined references to `errno' follow
Comment 1 Jakub Jelinek 2002-12-18 15:02:44 EST
errno is not a symbol anything should use. All users of errno need to properly
#include <errno.h> to get errno definition, seems Asbsoft is broken in this
regard and needs to be fixed.
Comment 2 Sammy 2002-12-18 15:07:57 EST
Perhaps the new upgrade fixes it but the same compiler did not give this error 
until recently. Anyway, if I add /usr/lib/libc.a to the link line it is fixed (not -lc). 
FYI 
Comment 3 Jakub Jelinek 2002-12-18 15:08:32 EST
*** Bug 80017 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2002-12-18 15:15:47 EST
It has been intentionally removed from glibc (well, with the exception of
TLS enabled glibc build it is kept there for compatibility as runtime only symbol,
but newly linked programs aren't allowed to reference it.
errno in linux has been *__errno_location() for some 4 years or how long,
this is the only way how to get the bugs fixed).
With TLS enabled glibc which is going to rawhide RSN it is technically
impossible to leave errno in (ld.so will automatically take care of
GLIBC 2.0 compiled binaries and libs they use because __errno_location did not
exist in there) and for more recent but buggy applications one can use
LD_ASSUME_KERNEL=2.2.5 at runtime.
Comment 5 arnet 2003-05-07 12:10:48 EDT
Some info for people with this problem:
Absoft provides a patch fixing this bug (in their software). You can download it at
http://www.absoft.com/download/pub/linux/profortran8.0/ProFortran80QFIO.tar.gz

This is a fix for ProFortran 8.0, but I've tested it also on ProFortran 6.0 and orks
Comment 6 jackcheng 2005-11-10 03:12:29 EST
(In reply to comment #5)
> Some info for people with this problem:
> Absoft provides a patch fixing this bug (in their software). You can download
it at
> http://www.absoft.com/download/pub/linux/profortran8.0/ProFortran80QFIO.tar.gz
> 
> This is a fix for ProFortran 8.0, but I've tested it also on ProFortran 6.0
and orks

After I used the patch which downloaded at
http://www.absoft.com/download/pub/linux/profortran8.0/ProFortran80QFIO.tar.gz
but when I compiled. the err still exist. My PC is RHAS update2, the version of
absoft compiler which I using is 7.5.

Note You need to log in before you can comment on or make changes to this bug.