Bug 800234 - man page out of date
man page out of date
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 23:45 EST by Steve
Modified: 2012-11-22 21:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 10:31:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox man page from Ubuntu-Studio 12.04 (943 bytes, application/x-gzip)
2012-04-28 09:59 EDT, Steve
no flags Details

  None (edit)
Description Steve 2012-03-05 23:45:16 EST
Description of problem:
man page out of date
lists firefox date August 07, 2001    

Version-Release number of selected component (if applicable):
not applicable

How reproducible:
always

Steps to Reproduce:
1. man firefox 
 
Actual results:
man page date August 07, 2001

Expected results:
man page relevant to current version
option -no-remote not listed
Comment 1 Steve 2012-03-05 23:47:36 EST
open a Mint-12 system
man firefox shows date of 2011-02-09
Comment 2 Jan Horak 2012-04-05 04:46:19 EDT
Thanks for you report. Could you please attach updated manual page?
Comment 3 Steve 2012-04-28 09:59:23 EDT
Created attachment 580971 [details]
firefox man page from Ubuntu-Studio 12.04
Comment 4 Sergio 2012-10-04 22:59:09 EDT
firefox --help : http://paste.org/55041
man firefox : http://paste.org/55043

Maybe tomorrow I try to update the man page and post here (if anyone doesn't do it before).
Comment 5 Sergio 2012-10-05 10:16:18 EDT
Here's the updated man page: http://paste.org/55060
Comment 6 Sergio 2012-10-11 08:26:55 EDT
Hi guys, shipping an outdated man page is misleading. Once I had trouble with Firefox and kept wondering why it had dropped the safe-mode option because it wasn't in the man page (and since there was a man page I never thought of trying 'firefox -h').
So either use the updated man page or maybe even better for maintenance is to do like with Thunderbird and don't ship any man page at all.
Comment 7 Martin Stransky 2012-10-11 17:28:54 EDT
Thanks. But I'm not sure we can just ship a manpage which is copied from Ubuntu. Which license does the Ubuntu man page have?
Comment 8 Sergio 2012-10-11 18:08:36 EDT
That updated man page (comment #5) I did myself, with some help of help2man.
Comment 9 Sergio 2012-10-11 18:18:53 EDT
http://paste.org/55367
Fixed a little thing (replaced 'Print this message' for 'Print all command-line options').
Comment 10 Martin Stransky 2012-10-12 02:48:42 EDT
Great, Thanks! 

Could you please include other common sections like VERSION, SEE ALSO, AUTHORS? You may also state that you created the man page but I'm not sure where it's supposed to be placed.

As for the SEE ALSO section, if you create a man page for other products (thunderbird, xulrunner, seamonkey?) we'll update those man pages too.

Thanks again!
Comment 11 Sergio 2012-10-12 06:34:29 EDT
(In reply to comment #10)

> Could you please include other common sections like VERSION, SEE ALSO,
> AUTHORS? You may also state that you created the man page but I'm not sure
> where it's supposed to be placed.
> 

According to http://kernel.org/doc/man-pages/online/pages/man7/man-pages.7.html

VERSIONS doesn't seem to be relevant here (or is it?).
AUTHORS is "strongly discouraged" (and the contents for firefox.1 is 90%+ just 'firefox -h')

> As for the SEE ALSO section, if you create a man page for other products
> (thunderbird, xulrunner, seamonkey?) we'll update those man pages too.
> 

I don't know if thunderbird/seamonkey are related to the point of being in the SEE ALSO section as they don't interfere with firefox, I think.
xulrunner probably yes and it has a simple help output. I could make a man page for it but I would have to first look at what it is and how it interferes with the mozilla apps so I don't know yet when I'll do it.
Comment 12 Martin Stransky 2012-10-30 10:31:03 EDT
Thanks, added to rawhide.
Comment 13 Steve 2012-11-22 21:00:08 EST
upgraded to firefox-17.0
still providing man page dated August 07, 2001

Note You need to log in before you can comment on or make changes to this bug.