Bug 800273 - Cancel button on "New component Outline" page should launch the "Clouds" Page
Cancel button on "New component Outline" page should launch the "Clouds" Page
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Jozef Zigmund
wes hayutin
: Triaged
: 801325 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 03:07 EST by Shveta
Modified: 2012-12-04 09:57 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clicking the cancel button on "New Cloud Resource Zone" and "New Image" pages directed users to the "Monitor" page. This bug fix updates two files in Conductor: new.html.haml and _form.html.haml. Clicking the cancel button takes users to the previous page instead of the "Monitor" page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:57:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upload_cancel (215.38 KB, image/png)
2012-03-06 03:07 EST, Shveta
no flags Details
launched_page (204.91 KB, image/png)
2012-03-06 03:09 EST, Shveta
no flags Details
new_CRZ_cancel (202.64 KB, image/png)
2012-03-06 04:41 EST, Shveta
no flags Details

  None (edit)
Description Shveta 2012-03-06 03:07:36 EST
Created attachment 567863 [details]
upload_cancel

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Clouds -- New component Outline
2. Upload -- click cancel
3. default cloud page is launched ..

rather main cloud page from where we started should be launched.
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-daemons-0.8.0-40.el6.noarch
aeolus-configure-2.5.0-17.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.0-40.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-all-0.8.0-40.el6.noarch
aeolus-conductor-doc-0.8.0-40.el6.noarch
Comment 1 Shveta 2012-03-06 03:09:01 EST
Created attachment 567864 [details]
launched_page
Comment 2 Shveta 2012-03-06 04:41:25 EST
Created attachment 567881 [details]
new_CRZ_cancel

Cloud -- New Resource Zone -- cancel
It takes to minitor page , should launch cloud page
Comment 3 Jozef Zigmund 2012-03-20 06:20:33 EDT
Bugfix was posted https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009623.html
Comment 4 Jozef Zigmund 2012-03-20 08:09:21 EDT
*** Bug 801325 has been marked as a duplicate of this bug. ***
Comment 5 Jozef Zigmund 2012-03-21 06:17:01 EDT
Bugfix was pushed to master branch, commit # 81267ec05213b54d48185beaa40d27cefbba55ee
Please verify it.
Comment 7 pushpesh sharma 2012-09-20 07:23:09 EDT
1. Clouds -- New image
2. Upload -- click cancel
3. Main page at Cloud tab is launched (From where it is started)

Or:-

1. Clouds -- New Cloud Resource Zone 
2. Click cancel
3. Main page at Cloud tab is launched(From where it is started)


Verified On:-
[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
Comment 9 errata-xmlrpc 2012-12-04 09:57:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.