This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 800283 - Reverse zone name is appended as part of the domain.
Reverse zone name is appended as part of the domain.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 03:31 EST by Gowrishankar Rajaiyan
Modified: 2012-03-06 07:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 07:10:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-03-06 03:31:49 EST
Description of problem:


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-2.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
[root@primenova ~]# hostname 
primenova.lab.eng.pnq.redhat.com
[root@primenova ~]# nslookup `hostname`
Server:		10.65.255.201
Address:	10.65.255.201#53

Non-authoritative answer:
Name:	primenova.lab.eng.pnq.redhat.com
Address: 10.65.201.100

[root@primenova ~]# cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
[root@primenova ~]#


[root@primenova ~]# ipa-server-install --setup-dns

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

To accept the default shown in brackets, press the Enter key.

Existing BIND configuration detected, overwrite? [no]: yes
Enter the fully qualified domain name of the computer
on which you're setting up server software. Using the form
<hostname>.<domainname>
Example: master.example.com.


Server host name [primenova.lab.eng.pnq.redhat.com.201.65.10.in-addr.arpa]: 

Warning: skipping DNS resolution of host primenova.lab.eng.pnq.redhat.com.201.65.10.in-addr.arpa
The domain name has been calculated based on the host name.

Please confirm the domain name [lab.eng.pnq.redhat.com.201.65.10.in-addr.arpa]:
  
Actual results:
Reverse zone name is appended as part of the domain when host entry doesn't exist in /etc/hosts.

Expected results:
Reverse zone name should not be appended.

Additional info:
Comment 2 Martin Kosek 2012-03-06 07:10:39 EST
As discussed with the reporter, this is not a bug. There was an issue with DNS configuration where reverse DNS lookups returned an invalid domain.

Note You need to log in before you can comment on or make changes to this bug.