This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 800308 - Edit cloud resource zone page should have only one "Cancel" button
Edit cloud resource zone page should have only one "Cancel" button
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: beta5
: ---
Assigned To: Jiri Tomasek
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 04:35 EST by Rehana
Modified: 2012-05-15 18:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
UI (202.14 KB, image/png)
2012-03-06 04:35 EST, Rehana
no flags Details
Observation 2 (198.34 KB, image/png)
2012-03-06 04:55 EST, Rehana
no flags Details

  None (edit)
Description Rehana 2012-03-06 04:35:15 EST
Created attachment 567880 [details]
UI

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to conductor
2.move to clouds
3.click on "edit" button displayed against the "Default" cloud resource zone
  
Actual results:
Observed that the edit page has two "Cancel" buttons with same functionality(PFA: UI.png)

Expected results:
The page should have only one cancel button, and on clicking the button it should go to the appropriate page( or the previous page from which the user clicked edit)

Additional info:
[root@ibm-ls22-03 ~]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.0-39.el6.noarch
aeolus-configure-2.5.0-16.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-all-0.8.0-39.el6.noarch
rubygem-aeolus-image-0.3.0-11.el6.noarch
aeolus-conductor-0.8.0-39.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
Comment 1 Rehana 2012-03-06 04:54:55 EST
Observation #2

Edit "Catalog" page is having two buttons "Cancel Editing" and "Cancel" button doing the same functionality. On click of these button, the user is taken to "Catalog" page.

Expected result:
The page is expected to have only one "cancel" button that takes the user to "Catalog" page
Comment 2 Rehana 2012-03-06 04:55:39 EST
Created attachment 567894 [details]
Observation 2
Comment 3 Jiri Tomasek 2012-03-09 09:50:58 EST
fix posted in https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009499.html
Comment 4 Jiri Tomasek 2012-03-12 11:54:32 EDT
fixed in commit 285f0e0a47e519cf1241b4a6b0ee791c33ca9d73
Comment 6 Rehana 2012-03-15 03:34:21 EDT
Observed that now only one cancel button is displayed in the pages mentioned above.

Verified in 
rpm -qa | grep aeolus
aeolus-configure-2.5.0-18.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-all-0.8.0-43.el6.noarch
Comment 7 errata-xmlrpc 2012-05-15 18:48:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.