Bug 800318 - installer fails: Working directory '/var/www/html/pub' does not exist
installer fails: Working directory '/var/www/html/pub' does not exist
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: 6.0
Assigned To: Martin Bacovsky
Katello QA List
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 04:55 EST by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs of install fail (35.03 KB, application/x-gzip)
2012-03-06 04:55 EST, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2012-03-06 04:55:36 EST
Created attachment 567893 [details]
logs of install fail

Description of problem:
On recent nightly Katello installation process fails: doing installation as usual

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120306-034421/main.log]
[1;35merr: /Stage[main]/Certs::Config/Exec[generate-candlepin-consumer-certificate]/returns: change from notrun to 0 failed: Working directory '/var/www/html/pub' does not exist[0m
[1;35merr: /Stage[main]/Certs::Config/Exec[generate-candlepin-consumer-certificate]: Failed to call refresh: Working directory '/var/www/html/pub' does not exist[0m


Expected results:
no error.

Additional info:
attached are the logs
Comment 1 Martin Bacovsky 2012-03-06 05:29:39 EST
This issue could affect System Engine as well. Changing product to acquire acks
Comment 2 Martin Bacovsky 2012-03-06 06:01:33 EST
This issue was fixed in katello-configure-0.2.8-1. 
Commit hash: 40d586a9e28b47acc9e0770b77d1f0a2db105ccd
Comment 3 Garik Khachikyan 2012-03-06 07:45:03 EST
QE acked. and just check the latest Katello package(s) - issue is fixed.
Comment 5 Corey Welton 2012-03-08 10:56:45 EST
Looks like Garik verified in comment #3, and having successfully installed, it's obviously fixed.

Note You need to log in before you can comment on or make changes to this bug.