Bug 800319 - Invocation of useradd without specifying a UID
Invocation of useradd without specifying a UID
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 05:04 EST by Vitezslav Crhonek
Modified: 2013-02-21 05:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:24:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to fix the uid/gid creation (1.50 KB, patch)
2012-06-29 04:36 EDT, Tuomo Soini
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0418 normal SHIPPED_LIVE tog-pegasus bug fix and enhancement update 2013-02-20 15:49:45 EST

  None (edit)
Description Vitezslav Crhonek 2012-03-06 05:04:00 EST
Description of problem:

tog-pegasus-libs RPM script calls useradd to create cimsrvr user/group without specifying a UID which is not correct.

There's reserved 134:134 uidgid pair for cimsrvr already, see:
https://bugzilla.redhat.com/show_bug.cgi?id=760178

useradd should use this pair.
Comment 1 Tuomo Soini 2012-06-29 04:36:05 EDT
Created attachment 595232 [details]
Proposed patch to fix the uid/gid creation
Comment 8 errata-xmlrpc 2013-02-21 05:24:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0418.html

Note You need to log in before you can comment on or make changes to this bug.