Bug 800338 - Taking screenshot hangs Spice display when a client is connected
Taking screenshot hangs Spice display when a client is connected
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Michal Privoznik
Virtualization Bugs
:
Depends On: 747011
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 05:50 EST by Alon Levy
Modified: 2014-04-01 05:04 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 747011
Environment:
Last Closed: 2014-04-01 05:04:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 7 RHEL Product and Program Management 2012-07-10 03:57:37 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 19:51:07 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 Michal Privoznik 2012-09-21 07:51:32 EDT
Alon,

IIUC, the patches for screendump-async aren't merged yet. Is that right?
Because was unable to find such command in upstream and RHEL qemu too.

From my understanding, none of the patches fixing qemu part (Bug 747011) introduce such command. So do you happen to fix it without any API/ABI change?
Comment 11 Alon Levy 2012-10-02 08:05:29 EDT
(In reply to comment #9)
> Alon,
> 
> IIUC, the patches for screendump-async aren't merged yet. Is that right?
> Because was unable to find such command in upstream and RHEL qemu too.
> 
> From my understanding, none of the patches fixing qemu part (Bug 747011)
> introduce such command. So do you happen to fix it without any API/ABI
> change?

This bug has not been fixed, like you noticed there is no new event or command.

Alon
Comment 15 Michal Privoznik 2014-04-01 05:04:31 EDT
This bug seems fixed to me. I mean looking at https://bugzilla.redhat.com/show_bug.cgi?id=747011#c18 it seems like taking screenshot via virsh works well and no hang up occurs. Therefore I'm closing this one. If you disagree, please reopen.

Note You need to log in before you can comment on or make changes to this bug.