Bug 800404 - iwidgets introduction demo fails
iwidgets introduction demo fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iwidgets (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dmitrij S. Kryzhevich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 07:56 EST by John Ellson
Modified: 2012-08-28 19:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 19:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2012-03-06 07:56:55 EST
Description of problem:
The iwidgets demo fails because its tries to use wish8.4, but wish 8.5 is current.

The failure is easy for an experienced user to fix, but this is the introductory demo for new users of iwidgets.

Version-Release number of selected component (if applicable):
iwidgets-4.0.2-6.fc17

How reproducible:
100%

Steps to Reproduce:
1. /usr/share/tcl8.5/iwidgets4.0.2/demos/catalog
2.
3.
  
Actual results:
/usr/share/tcl8.5/iwidgets4.0.2/demos/catalog: line 13: exec: wish8.4: not found

Expected results:
a window full of nice widgets

Additional info:
change line 13 to use wish8.5 and it all works fine
Comment 1 John Ellson 2012-03-06 08:24:20 EST
Using "package require Tk 8.4"  will check for 8.4 as a min version, so I'd suggest:

$ diff catalog.orig catalog
1c1
< #!/bin/sh
---
> #!/bin/env tclsh
12,13c12
< #\
< exec wish8.4 "$0"
---
> #
14a14
> package require Tk 8.4
Comment 2 John Ellson 2012-03-06 08:27:58 EST
Actually, even "package require Tk 8.4" can be removed, since "package require Iwidgets 4.0" does it implicitly.
Comment 3 Dmitrij S. Kryzhevich 2012-03-15 00:12:07 EDT
I'l see in a coule of days.
Comment 4 John Ellson 2012-08-26 12:21:33 EDT
Ping ?


Not yet fixed.
iwidgets-4.0.2-6.fc17.noarch
iwidgets-4.0.2-6.fc17.noarch
Comment 5 Fedora Update System 2012-08-28 05:33:02 EDT
iwidgets-4.0.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/iwidgets-4.0.2-8.fc17
Comment 6 Dmitrij S. Kryzhevich 2012-08-28 05:34:24 EDT
Some sort of pong, I think.
Comment 7 Fedora Update System 2012-08-28 19:31:29 EDT
iwidgets-4.0.2-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.