Bug 800418 - [abrt] blueman-1.21-10.fc16: utils.py:28:warp:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.Headset" doesn't exist
[abrt] blueman-1.21-10.fc16: utils.py:28:warp:DBusException: org.freedesktop....
Status: CLOSED DUPLICATE of bug 770434
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:3b033539c3e28ce834d5ccaa3c2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 08:19 EST by Andre Vehreschild
Modified: 2012-04-26 16:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 16:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Vehreschild 2012-03-06 08:19:08 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/blueman-manager
executable:     /usr/bin/blueman-manager
kernel:         3.2.7-1.fc16.x86_64
reason:         utils.py:28:warp:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.Headset" doesn't exist
time:           Tue 06 Mar 2012 02:17:19 PM CET
uid:            1000
username:       vehre

backtrace:
:utils.py:28:warp:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.Headset" doesn't exist
:
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/blueman/gui/manager/ManagerDeviceMenu.py", line 219, in on_device_property_changed
:    self.Generate()
:  File "/usr/lib/python2.7/site-packages/blueman/gui/manager/ManagerDeviceMenu.py", line 449, in Generate
:    sprops = service.GetProperties()
:  File "/usr/lib/python2.7/site-packages/blueman/bluez/utils.py", line 28, in warp
:    raise errors.parse_dbus_error(exception)
:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.Headset" doesn't exist
:
:
:Local variables in innermost frame:
:exception: DBusException('Method "GetProperties" with signature "" on interface "org.bluez.Headset" doesn\'t exist\n',)
:args: ()
:func: <dbus.proxies._ProxyMethod instance at 0x1cd6cf8>
:kwargs: {}

comment:
:Disconnecting an audio sink from a headset.
:After that tryed to disconnect a headset service and  it crashed.

smolt_data:
:
:
:General
:=================================
:UUID: 4f023a06-5573-4f1c-85a5-93aaedca2d78
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5999.00
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) 64 X2 Dual Core Processor 5800+
:CPU Stepping: 2
:CPU Family: 15
:CPU Model Num: 107
:Number of CPUs: 2
:CPU Speed: 3000
:System Memory: 3703
:System Swap: 4095
:Vendor: To Be Filled By O.E.M.
:System: To Be Filled By O.E.M. To Be Filled By O.E.M.
:Form factor: Desktop
:Kernel: 3.2.7-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17308:4187:3600) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17304:4187:3600) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:38417:4187:3600) pci, fglrx_pci, VIDEO, Radeon 3100 Graphics
:(4332:33127:4187:3600) pci, r8169, ETHERNET, RTL-8110SC/8169SC Gigabit Ethernet
:(4098:17296:4187:3600) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
:(4098:17285:4187:3600) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17309:4187:3600) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:4187:3600) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:4187:3600) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:17302:4187:3600) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4098:17303:4187:3600) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4130:38400:4130:38400) pci, None, HOST/PCI, RS780 Host Bridge
:(4130:38402:4130:38402) pci, None, PCI/PCI, RS780/RS880 PCI to PCI bridge (int gfx)
:(4098:17302:4187:3600) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17304:4187:3600) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:17303:4187:3600) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 5088235 2510440 2459503 1277952 884060 884060
:/dev/mapper/vg_pwpc02-var /var ext4 4096 4096 5103904 4874780 4618780 1281120 1270382 1270382
:/dev/mapper/vg_pwpc02-usrlocal /usr/local ext4 4096 4096 12778715 12556826 11916622 3203072 3202991 3202991
:/dev/mapper/_dev_dm_2 WITHHELD ext4 4096 4096 26174432 23521769 22211075 6553600 6067047 6067047
:
Comment 1 Andre Vehreschild 2012-03-08 07:05:06 EST
Disconnecting a bluetooth headset.

Package: blueman-1.21-10.fc16
OS Release: Fedora release 16 (Verne)
Comment 2 Christoph Wickert 2012-04-26 16:46:56 EDT

*** This bug has been marked as a duplicate of bug 770434 ***

Note You need to log in before you can comment on or make changes to this bug.