This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 800431 - missing valgrind suppressions for _dl_start and __strcasestr_sse42
missing valgrind suppressions for _dl_start and __strcasestr_sse42
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: valgrind (Show other bugs)
7.0
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
: Regression, Reopened
: 801841 (view as bug list)
Depends On: 702488
Blocks: 705309
  Show dependency treegraph
 
Reported: 2012-03-06 08:40 EST by Petr Sklenar
Modified: 2013-01-10 23:09 EST (History)
9 users (show)

See Also:
Fixed In Version: valgrind-3.8.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 702488
Environment:
Last Closed: 2012-10-17 16:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Mark Wielaard 2012-09-10 03:24:54 EDT
Both these seem fine in valgrind-3.8.0:

$ valgrind ./test -v
==1363== Memcheck, a memory error detector
==1363== Copyright (C) 2002-2012, and GNU GPL'd, by Julian Seward et al.
==1363== Using Valgrind-3.8.0 and LibVEX; rerun with -h for copyright info
==1363== Command: ./test -v
==1363== 
Result: 0x7ff000180
HeLLo I Am eMo KiD==1363== 
==1363== HEAP SUMMARY:
==1363==     in use at exit: 0 bytes in 0 blocks
==1363==   total heap usage: 0 allocs, 0 frees, 0 bytes allocated
==1363== 
==1363== All heap blocks were freed -- no leaks are possible
==1363== 
==1363== For counts of detected and suppressed errors, rerun with: -v
==1363== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 2 from 2)
Comment 7 Mark Wielaard 2012-10-05 10:00:44 EDT
*** Bug 801841 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.