Bug 800442 - Add capability to run user scripts from userdata in RHEL AMIs
Add capability to run user scripts from userdata in RHEL AMIs
Status: CLOSED DUPLICATE of bug 838659
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cloud-init (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joe Vlcek
mkovacik
: EC2
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 08:49 EST by Chris Morgan
Modified: 2012-10-25 09:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 09:29:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Morgan 2012-03-06 08:49:07 EST
Request from Amazon:

We have a request from a customer to have RHEL AMI output the ssh fingerprints
to the console on boot.  This allows our customers to verify that the host they
are ssh'ing to is the same host that is in their account in the console.  We
also recommend this to customers in the EC2 User Guide:
http://docs.amazonwebservices.com/AWSEC2/latest/UserGuide/AccessingInstancesLinux.html

The customer would have setup a script to output these himself but the RHEL
amis don't currently have a mechanism to run user scripts from the userdata.

---------------------

Would like to target this for any future regions (add it to all AMIs) and for
existing regions, only add it to new versions of RHEL.
Comment 3 Suzanne Yeghiayan 2012-05-18 16:52:22 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Jay Greguske 2012-05-21 13:52:23 EDT
Note that integration of the cloud-init package may solve this.
Comment 5 RHEL Product and Program Management 2012-07-10 02:59:33 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:47:40 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 Joe Vlcek 2012-10-25 09:29:57 EDT
Note that integration of the cloud-init package will solve this.

*** This bug has been marked as a duplicate of bug 838659 ***

Note You need to log in before you can comment on or make changes to this bug.