Bug 800483 - Unable to delete records interactively.
Unable to delete records interactively.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 09:44 EST by Gowrishankar Rajaiyan
Modified: 2012-06-20 09:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipa-2.2.0-4.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:20:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-03-06 09:44:49 EST
Description of problem:


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
[root@primenova ~]# ipa dnsrecord-find example.com
  Record name: @
  NS record: primenova.lab.eng.pnq.redhat.com.

  Record name: foo
  A record: 10.0.1.1
----------------------------
Number of entries returned 2
----------------------------

[root@primenova ~]# ipa dnsrecord-del example.com
Record name: foo
No option to delete specific record provided.
Delete all? Yes/No (default No): Yes
Delete all? Yes/No (default No): Yes
Delete all? Yes/No (default No): Yes
Delete all? Yes/No (default No): 
Current DNS record contents:

A record: 10.0.1.1

Delete A record '10.0.1.1'? Yes/No (default No): Yes
Delete A record '10.0.1.1'? Yes/No (default No): Yes
Delete A record '10.0.1.1'? Yes/No (default No): Yes
Delete A record '10.0.1.1'? Yes/No (default No): 
ipa: ERROR: Neither --del-all nor options to delete a specific record provided.
Command help may be consulted for all supported record types.
[root@primenova ~]#

Actual results: Unable to delete records interactively.


Expected results: Should be able to delete records.


Additional info:
Works as expected when given as cli option:
# ipa dnsrecord-del example.com foo --a-rec=10.0.1.1 
--------------------
Deleted record "foo"
--------------------


# ipa dnsrecord-del example.com foo --del-all
--------------------
Deleted record "foo"
--------------------
Comment 1 Martin Kosek 2012-03-06 09:51:08 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2484
Comment 5 Gowrishankar Rajaiyan 2012-03-23 03:58:08 EDT
[root@primenova ~]# ipa dnsrecord-find example.com
  Record name: @
  NS record: primenova.lab.eng.pnq.redhat.com.

  Record name: foo
  A record: 10.10.10.10
----------------------------
Number of entries returned 2
----------------------------
[root@primenova ~]# ipa dnsrecord-del example.com
Record name: foo
No option to delete specific record provided.
Delete all? Yes/No (default No): Yes
--------------------
Deleted record "foo"
--------------------
[root@primenova ~]# 
[root@primenova ~]# ipa dnsrecord-find example.com
  Record name: @
  NS record: primenova.lab.eng.pnq.redhat.com.
----------------------------
Number of entries returned 1
----------------------------
[root@primenova ~]# 


[root@primenova ~]# ipa dnsrecord-find example.com
  Record name: @
  NS record: primenova.lab.eng.pnq.redhat.com.

  Record name: foo
  A record: 10.1.1.1
----------------------------
Number of entries returned 2
----------------------------
[root@primenova ~]# ipa dnsrecord-del example.com
Record name: foo
No option to delete specific record provided.
Delete all? Yes/No (default No): yes
--------------------
Deleted record "foo"
--------------------
[root@primenova ~]# ipa dnsrecord-find example.com
  Record name: @
  NS record: primenova.lab.eng.pnq.redhat.com.
----------------------------
Number of entries returned 1
----------------------------
[root@primenova ~]# 


Verified in build: ipa-server-2.2.0-5.el6.x86_64
Comment 7 Martin Kosek 2012-04-24 09:34:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 errata-xmlrpc 2012-06-20 09:20:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.