Bug 800484 - regression in 6.2's HDIO_DRIVE_CMD ioctl
regression in 6.2's HDIO_DRIVE_CMD ioctl
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 09:47 EST by Levente Farkas
Modified: 2014-05-21 09:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-21 09:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2012-03-06 09:47:49 EST
until now (this means from rhel 5.0-rhel 6.1) both this command works:
hdparm -I /dev/sda
hdparm -I /dev/sda1
after rhel-6.2 the second is not working. the core reason is the 
ioctl(fd, HDIO_DRIVE_CMD, args);
kernel ioctl command which no longer works when called with the /dev/sda1's fd, but still working when use the /dev/sda's fd).
Comment 4 RHEL Product and Program Management 2012-05-03 00:46:10 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.