Bug 800551 - thumbslug returns 403
thumbslug returns 403
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 12:39 EST by Jakub Dorňák
Modified: 2016-11-30 19:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 05:55:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/thumbslug/*.log (1.15 KB, application/x-gzip)
2012-03-06 12:39 EST, Jakub Dorňák
no flags Details

  None (edit)
Description Jakub Dorňák 2012-03-06 12:39:37 EST
Created attachment 568016 [details]
/var/log/thumbslug/*.log

Description of problem:
After successfull registration to SAM, i can not install package. 


Version-Release number of selected component (if applicable):
thumbslug-0.0.21-1.el6.noarch

How reproducible:
2012-03-02.1 / x86_64

Steps to Reproduce:
1. install SAM with yum -y instsall katello-headpin-all
2. configure headpin with katello-configure --deployment=headpin
3. import manifest file (attached)
4. configure some system to use this SAM with subscription-manager config ...
5. register the system with subscription-manager register
6. autosubscribe the system with subscription-manager subscribe --auto
7. try to install package with yum install nmap

Actual results:

Installation fails:

[root@qb-sam ~]# yum install nmap
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
https://ibm-ls21-02.rhts.eng.rdu.redhat.com:8088/content/dist/rhel/server/6/6Server/x86_64/cf-tools/1.0/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-6-server-cf-tools-1-rpms. Please verify its path and try again



Expected results:

Package has been installed.


Additional info:
Particular thumbslug logs attached
Comment 3 Jakub Dorňák 2012-03-08 04:11:52 EST
Well, I thought it could be problem with the manifest file. So I checked the management at https://access.redhat.com/management and I discovered that the SAM organization, whose manifest file I use had got no subscriptions any more. (I am not asking why..)
So I added some subscriptions to that organization and downloaded new manifest.
But after the import of this new manifest into the SAM (and reregistration of the guest) I still had the 403 problem.
This is probably because SAM still used the broken subscriptions of the previous manifest file (probably until they are all used).
So I need to be able to disable or throw away anyhow the broken subscriptions in SAM. Or the SAM should even verify the certificate before it provides it to the guest...

In my situation it helped to reinstall the SAM and use only the new manifest, which is definitely not the ideal way to solve such problems..
Comment 8 Jakub Dorňák 2012-03-19 05:55:45 EDT
Closing this bug as NOTABUG, because it is a different issue regarding to the original report. I'll find more information and consider reporting new bug.

Note You need to log in before you can comment on or make changes to this bug.