Bug 800627 - redis package broken due to missing libtcmalloc.so
redis package broken due to missing libtcmalloc.so
Status: CLOSED DUPLICATE of bug 800693
Product: Fedora
Classification: Fedora
Component: redis (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Silas Sewell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 15:12 EST by nbrown
Modified: 2012-03-09 02:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 02:53:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nbrown 2012-03-06 15:12:28 EST
Description of problem:
When trying to install the redis RPM via yum on Fedora 15, dependencies are broken.

Version-Release number of selected component (if applicable):
redis.x86_64 0:2.2.5-1.fc15
2.6.38.6-26.rc1.fc15.x86_64
Fedora release 15 (Lovelock)


How reproducible:
Install redis 

Steps to Reproduce:
1. yum -d 10 install redis
  
Actual results:

--> Running transaction check
---> Package redis.x86_64 0:2.2.5-1.fc15 will be installed
Checking deps for redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('chkconfig', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('libpthread.so.0(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('logrotate', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('chkconfig', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('rtld(GNU_HASH)', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('initscripts', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('libc.so.6(GLIBC_2.7)(64bit)', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('shadow-utils', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('/bin/sh', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('libm.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('libtcmalloc.so.0()(64bit)', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
looking for ('libm.so.6()(64bit)', None, (None, None, None)) as a requirement of redis.x86_64 0:2.2.5-1.fc15 - u
redis-2.2.5-1.fc15.x86_64 requires: libtcmalloc.so.0()(64bit)
--> Processing Dependency: libtcmalloc.so.0()(64bit) for package: redis-2.2.5-1.fc15.x86_64
Searching pkgSack for dep: libtcmalloc.so.0()(64bit)
Running compare_providers() for [<YumAvailablePackageSqlite : google-perftools-1.7-1.fc15.x86_64 (0x269ed90)>, <YumAvailablePackageSqlite : google-perftools-1.7-1.fc15.i686 (0x269e150)>]
better arch in po google-perftools-1.7-1.fc15.x86_64
archdist compared google-perftools-1.7-1.fc15.i686 to google-perftools-1.7-1.fc15.x86_64 on x86_64
  Winner: google-perftools-1.7-1.fc15.x86_64
better arch in po google-perftools-1.7-1.fc15.x86_64
archdist compared google-perftools-1.7-1.fc15.i686 to google-perftools-1.7-1.fc15.x86_64 on ia32e
  Winner: google-perftools-1.7-1.fc15.x86_64
archdist compared google-perftools-1.7-1.fc15.x86_64 to google-perftools-1.7-1.fc15.i686 on x86_64
  Winner: google-perftools-1.7-1.fc15.x86_64
archdist compared google-perftools-1.7-1.fc15.x86_64 to google-perftools-1.7-1.fc15.i686 on ia32e
  Winner: google-perftools-1.7-1.fc15.x86_64
Best Order: [(<YumAvailablePackageSqlite : google-perftools-1.7-1.fc15.x86_64 (0x269ed90)>, -30), (<YumAvailablePackageSqlite : google-perftools-1.7-1.fc15.i686 (0x269e150)>, -1024)]
Not Updating Package that is obsoleted: google-perftools-1.7-1.fc15.x86_64
Not Updating Package that is obsoleted: google-perftools-1.7-1.fc15.i686
Running compare_providers() for [<YumAvailablePackageSqlite : google-perftools-libs-1.9.1-1.fc15.x86_64 (0x269ef90)>, <YumAvailablePackageSqlite : google-perftools-libs-1.9.1-1.fc15.i686 (0x269eb10)>]
archdist compared google-perftools-libs-1.9.1-1.fc15.x86_64 to google-perftools-libs-1.9.1-1.fc15.i686 on x86_64
  Winner: google-perftools-libs-1.9.1-1.fc15.x86_64
archdist compared google-perftools-libs-1.9.1-1.fc15.x86_64 to google-perftools-libs-1.9.1-1.fc15.i686 on ia32e
  Winner: google-perftools-libs-1.9.1-1.fc15.x86_64
better arch in po google-perftools-libs-1.9.1-1.fc15.x86_64
archdist compared google-perftools-libs-1.9.1-1.fc15.i686 to google-perftools-libs-1.9.1-1.fc15.x86_64 on x86_64
  Winner: google-perftools-libs-1.9.1-1.fc15.x86_64
better arch in po google-perftools-libs-1.9.1-1.fc15.x86_64
archdist compared google-perftools-libs-1.9.1-1.fc15.i686 to google-perftools-libs-1.9.1-1.fc15.x86_64 on ia32e
  Winner: google-perftools-libs-1.9.1-1.fc15.x86_64
Best Order: [(<YumAvailablePackageSqlite : google-perftools-libs-1.9.1-1.fc15.x86_64 (0x269ef90)>, 989), (<YumAvailablePackageSqlite : google-perftools-libs-1.9.1-1.fc15.i686 (0x269eb10)>, 0)]
Not Updating Package that is obsoleted: google-perftools-libs-1.9.1-1.fc15.x86_64
Not Updating Package that is obsoleted: google-perftools-libs-1.9.1-1.fc15.i686
Running compare_providers() for [<YumAvailablePackageSqlite : google-perftools-1.7-1.fc15.x86_64 (0x269ed90)>, <YumAvailablePackageSqlite : google-perftools-libs-1.9.1-1.fc15.x86_64 (0x269ef90)>]
Best Order: [(<YumAvailablePackageSqlite : google-perftools-libs-1.9.1-1.fc15.x86_64 (0x269ef90)>, 979), (<YumAvailablePackageSqlite : google-perftools-1.7-1.fc15.x86_64 (0x269ed90)>, -1024)]
TSINFO: Marking google-perftools-libs-1.9.1-1.fc15.x86_64 as install for redis-2.2.5-1.fc15.x86_64
Package google-perftools-libs is obsoleted by gperftools-libs, but obsoleting package does not provide for requirements
--> Finished Dependency Resolution
Dependency Process ending
SKIPBROKEN: redis-2.2.5-1.fc15.x86_64 from fedora has depsolving problems
SKIPBROKEN:  --> Package: redis-2.2.5-1.fc15.x86_64 (fedora)
  -->     Requires: libtcmalloc.so.0()(64bit)
  -->     Available: google-perftools-1.7-1.fc15.x86_64 (fedora)
  -->         libtcmalloc.so.0()(64bit)
  -->     Available: google-perftools-libs-1.9.1-1.fc15.x86_64 (updates)
  -->         libtcmalloc.so.0()(64bit)
  -->     Available: google-perftools-1.9.1-1.fc15.x86_64 (updates)
  -->         Not found
Running "postresolve" handler for "langpacks" plugin
Depsolve time: 0.140
Error: Package: redis-2.2.5-1.fc15.x86_64 (fedora)
           Requires: libtcmalloc.so.0()(64bit)
           Available: google-perftools-1.7-1.fc15.x86_64 (fedora)
               libtcmalloc.so.0()(64bit)
           Available: google-perftools-libs-1.9.1-1.fc15.x86_64 (updates)
               libtcmalloc.so.0()(64bit)
           Available: google-perftools-1.9.1-1.fc15.x86_64 (updates)
               Not found


Expected results:

Successful install
Comment 1 Fabian Deutsch 2012-03-09 02:53:07 EST

*** This bug has been marked as a duplicate of bug 800693 ***

Note You need to log in before you can comment on or make changes to this bug.