Bug 800654 - [RFE] Better way to reset CDS registration
[RFE] Better way to reset CDS registration
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: nodes (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
Preethi Thomas
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 16:14 EST by Jeff Ortel
Modified: 2013-09-27 10:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 10:50:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Ortel 2012-03-06 16:14:00 EST
We need a better way to reset CDS registration.  Currently, when a CDS is removed from a pulp server and not in communication with the agent on the CDS, it leaves the CDS in an unusable state.  The CDS won't allow registration because it /thinks/ its already registered.

Currently user have to ssh onto the CDS and delete the /var/lib/pulp-cds/.gofer/secret file manually.

Alternatives:

1. Provide a script on the CDS to clean up registration artifacts.

2. Support a /forced/ registration that requires and alternate form of auth such as user/password.

3. Other?
Comment 1 Jay Dobies 2012-04-02 15:32:01 EDT
Punting out of sprint 34. This may get realigned to 1.1 but I suspect it will be part of the v2 CDS implementation.
Comment 2 Michael Hrivnak 2013-09-27 10:50:33 EDT
CDS no longer exists in pulp. Closing.

Note You need to log in before you can comment on or make changes to this bug.