Bug 800663 - Desktop Pager not editable in LXDE
Desktop Pager not editable in LXDE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
16
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 16:46 EST by C. M. Trindade
Modified: 2012-03-07 16:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 16:21:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C. M. Trindade 2012-03-06 16:46:11 EST
Description of problem:
Using Fedora 16, kernel 3.2.6-3. Desktop Pager not editable in LXDE
Panel Preferences.

Version-Release number of selected component (if applicable):
lxpanel-0.5.6-2.fc15.i686.rpm

How reproducible:
Open Panel Preferences in LXDE or with new user account.

Steps to Reproduce:
1. lxpanelctl config
2. click the Panel Applets tab.
3. select Desktop Pager
  
Actual results:
The Edit button on the right is uneditable

Expected results:
The Edit button on the right should be editable

Additional info:
File .config/lxpanel/LXDE/panels/panel creates entry:
. . .
Plugin {
    type = pager
}
. . .
by default when adding new user. As a result I cannot add new pages.
Comment 1 Christoph Wickert 2012-03-07 04:26:06 EST
What makes you think it should be editable? This is simply not supported by lxpanel. There are other plugins where the edit buttons are greyed out, too.

The number and position of the desktops are defined by the window manager, this means by openbox.

And btw: This problem is not of high severity becauses "High" is defined as "Problem due to crashes, loss of data, severe memory, leak, etc." What you actually want is a feature request.
Comment 2 C. M. Trindade 2012-03-07 16:10:49 EST
Thanks,
Installation of Openbox Configuration Manager enables creation of additional desktops in LXDE. XFCE crashes too often to be usable and Cinnamon takes too much processor power.
Comment 3 Christoph Wickert 2012-03-07 16:21:11 EST
Ok, I am closing this bug now. If you want a feature in lxpanel, please file a but at http://sourceforge.net/tracker/?group_id=180858&atid=894872

Note You need to log in before you can comment on or make changes to this bug.