Bug 800696 - glib2 i686 and x86_64 compatible versions not available in f17 repos
glib2 i686 and x86_64 compatible versions not available in f17 repos
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 19:12 EST by Tom Horsley
Modified: 2012-03-07 14:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 14:28:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2012-03-06 19:12:41 EST
Description of problem:
Observe this transcript:

[root@zooty /]# yum install glib2.i686
Loaded plugins: downloadonly, fastestmirror, langpacks, presto, refresh-
              : packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror.hiwaay.net
 * rpmfusion-free-rawhide: mirror.hiwaay.net
 * rpmfusion-nonfree-rawhide: mirror.hiwaay.net
 * updates: mirror.umd.edu
 * updates-testing: mirror.hiwaay.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package glib2.i686 0:2.31.16-2.fc17 will be installed
--> Processing Dependency: libfam.so.0 for package: glib2-2.31.16-2.fc17.i686
--> Running transaction check
---> Package gamin.i686 0:0.1.10-12.fc17 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: glib2-2.31.16-2.fc17.i686 != glib2-2.31.18-1.fc17.x86_64

Usually these sorts of things get fixed, but it has been this way for many
days now, so I thought I'd go ahead and report it since I couldn't find
an existing bugzilla about it.

Version-Release number of selected component (if applicable):
glib2-2.31.16-2.fc17.i686
glib2-2.31.18-1.fc17.x86_64

How reproducible:
every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
yum error

Expected results:
compatible i686 and x86_64 versions in repo so I can install
32 bit programs that depend on glib2

Additional info:
Comment 1 Matthias Clasen 2012-03-07 14:28:37 EST
mirror issue, nothing I can do about

Note You need to log in before you can comment on or make changes to this bug.