Bug 800709 - [abrt] kernel: [518873.488312] WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/ssb/main.c:1139 ssb_tmslow_reject_bitmask+0x5d/0x90 [ssb]()
[abrt] kernel: [518873.488312] WARNING: at /builddir/build/BUILD/kernel-3.2.f...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:748c5b94131e513eefb47849e92...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 21:04 EST by Marc Milgram
Modified: 2012-03-22 14:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 14:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 John W. Linville 2012-03-07 10:05:12 EST
Is there a line just before the WARNING in dmesg that has "ssb: Backplane Revision" in it?  This looks like an unknown revision of the SSB bus...
Comment 2 Marc Milgram 2012-03-07 18:57:26 EST
Hi John,

Here are the few lines before "ssb: Backplane Revision":

Mar  6 20:13:03 delos NetworkManager[1028]: <info> (wlan0): bringing up device.
Mar  6 20:13:03 delos NetworkManager[1028]: NetworkManager[1028]: <info> (wlan0): bringing up device.
Mar  6 20:13:03 delos kernel: [518873.488277] ssb: Backplane Revision 0xF0000000


Usually I am able to use wireless on this machine, but not after this error.

Hmmm...  There is more data in dmesg:

[Tue Mar  6 20:11:40 2012] usb 6-2: USB disconnect, device number 4
[Tue Mar  6 20:11:42 2012] tg3 0000:09:00.0: p3p1: Link is down
[Tue Mar  6 20:11:45 2012] dell_wmi: Unknown key e044 pressed
[Tue Mar  6 20:13:02 2012] ssb: Backplane Revision 0xF0000000

The tg3 link down and usb disconnect are expected as I was disconnecting my laptop so I could use it at a different location - wirelessly.

There were also some errors after this trace:
[Tue Mar  6 20:13:03 2012] b43-phy0 ERROR: Microcode not responding
[Tue Mar  6 20:13:03 2012] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
[Tue Mar  6 20:13:48 2012] keyboard: can't emulate rawmode for keycode 240
[Tue Mar  6 20:13:48 2012] keyboard: can't emulate rawmode for keycode 240
[Tue Mar  6 20:13:54 2012] keyboard: can't emulate rawmode for keycode 240
[Tue Mar  6 20:13:54 2012] keyboard: can't emulate rawmode for keycode 240
Comment 3 John W. Linville 2012-03-12 11:25:36 EDT
That looks like the hardware is not responding correctly.  Are you sure that device is still functional?  Could it have not been fully seated in the slot?
Comment 4 Marc Milgram 2012-03-12 20:41:06 EDT
After rebooting, my wireless card works just fine.  I don't use wireless most days with this machine.

I did notice that I had installed a new kernel, but not rebooted before I had the problem.
Comment 5 Dave Jones 2012-03-22 13:07:41 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Dave Jones 2012-03-22 13:10:44 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Dave Jones 2012-03-22 13:20:47 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Note You need to log in before you can comment on or make changes to this bug.