Bug 800751 - Disk smart values after resuming from hibernation not available
Disk smart values after resuming from hibernation not available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
first=3.3 hibernate smart
:
: 800745 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 01:52 EST by Joachim Backes
Modified: 2013-03-14 13:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 13:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2012-03-07 01:52:48 EST
Description of problem:
Having the problem that after *resuming from hibernation* the system is
not able to read the disk smart data from all my disks (sata):
-------------------------------------------------------------------------
sudo smartctl -a /dev/sda

smartctl 5.42 2011-10-20 r3458
[x86_64-linux-3.3.0-0.rc5.git3.1.fc17.x86_64] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Model Family:     Western Digital Caviar Blue Serial ATA
Device Model:     WDC WD5000AAKS-00UU3A0
Serial Number:    WD-WCAYU0114219
LU WWN Device Id: 5 0014ee 1ad259f8f
Firmware Version: 01.03B01
User Capacity:    500,107,862,016 bytes [500 GB]
Sector Size:      512 bytes logical/physical
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   8
ATA Standard is:  Exact ATA specification draft version not indicated
Local Time is:    Sun Mar  4 08:10:00 2012 CET
SMART support is: Available - device has SMART capability.
SMART support is: Disabled
----------------------------------------------------------------------------

I have to start the smartctl cmd again with the additional parameter "-s
on". Then the smart data are available.

Version-Release number of selected component (if applicable):
Kernel: 3.3.0-0.rc5.git3.1.fc17.x86_64

How reproducible:
Always after resuming from hibernation

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
1. After booting I can immediately read the smart values.
2. I'm wondering about the last 2 msg lines:

SMART support is: Available - device has SMART capability.
SMART support is: Disabled
Comment 1 Dave Jones 2012-03-07 10:25:25 EST
*** Bug 800745 has been marked as a duplicate of this bug. ***
Comment 2 Justin M. Forbes 2012-12-07 11:10:19 EST
Is this still an issue with 3.6.9 kernels?
Comment 3 Joachim Backes 2012-12-07 12:32:54 EST
(In reply to comment #2)
> Is this still an issue with 3.6.9 kernels?

No, seems to be solved (I'm actually running kernel-3.6.9-4.fc18.x86_64).

Note You need to log in before you can comment on or make changes to this bug.