Bug 800766 - [doc] The unit for max migration bandwidth should be Mbps not kilobytes/second
[doc] The unit for max migration bandwidth should be Mbps not kilobytes/second
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Sys-Virt (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 03:00 EST by xhu
Modified: 2012-06-20 08:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: perl-Sys-Virt-0.9.10-3.el6
Doc Type: Bug Fix
Doc Text:
No technical notes required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:01:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xhu 2012-03-07 03:00:25 EST
Description of problem:
The unit for max migration bandwidth should be Mbps not kilobytes/second

Version-Release number of selected component (if applicable):
perl-Sys-Virt-0.9.10-2.el6.x86_64
libvirt-0.9.10-4.el6.x86_64
qemu-kvm-0.12.1.2-2.234.el6.x86_64

How reproducible:
everytimes

Steps to Reproduce:
1. check usage for migrate_set_max_speed and migrate_get_max_speed
# man /usr/share/man/man3/Sys::Virt::Domain.3pm.gz
...
$dom->migrate_set_max_speed($bandwidth, $flags)
    Set the maximum allowed bandwidth during migration of the guest.  The
    "bandwidth" parameter is measured in kilobytes/second.  The 
    $flags parameter is currently unused and defaults to zero.

$bandwidth = $dom->migrate_get_max_speed($flag)
    Get the maximum allowed bandwidth during migration fo the guest.  The  
    returned <bandwidth> value is measured in kilobytes/second.  The
    $flags parameter is currently unused and defaults to zero.
...

2. use set-migrate-speed.pl to set max migrate speed:
# cat set-migrate-speed.pl
#!/usr/bin/perl
use warnings;
use strict;
use Sys::Virt;

my $uri = "qemu:///system";
my $domname = "vr-rhel6-x86_64-kvm";
my $bandwidth = 2;
my $flags = 0;

my $con = Sys::Virt->new(address => $uri, readonly => 0);
my $dom = $con->get_domain_by_name($domname);

$dom->migrate_set_max_speed($bandwidth, $flags);
$bandwidth = $dom->migrate_get_max_speed($flags);

3. use "virsh migrate-getspeed" to check:
# virsh migrate-getspeed vr-rhel6-x86_64-kvm
2

# virsh help migrate-getspeed
...
  DESCRIPTION
    Get the maximum migration bandwidth (in Mbps) for a domain.
...

Actual results:
The unit for max migration bandwidth is kilobytes/second

Expected results:
The unit for max migration bandwidth should be Mbps

Additional info:
Comment 1 Daniel Berrange 2012-03-16 07:34:39 EDT
Fix upstream

commit 6608ce471c40589563e1811d445466facd290897
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Fri Mar 16 11:28:11 2012 +0000

    Fix units for migration bandwidth docs
Comment 6 xhu 2012-03-20 06:30:34 EDT
According to comment 4 and 5, change it to verified status.
Comment 8 Daniel Berrange 2012-05-01 05:08:46 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No technical notes required
Comment 10 errata-xmlrpc 2012-06-20 08:01:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0754.html

Note You need to log in before you can comment on or make changes to this bug.