Bug 800781 - iSCSI login fails when portal has multiple targets and iSNS is running.
iSCSI login fails when portal has multiple targets and iSNS is running.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scsi-target-utils (Show other bugs)
6.3
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Andy Grover
Martin Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 03:43 EST by Bruno Goncalves
Modified: 2017-12-06 07:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:58:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from Bruno (4.10 KB, text/plain)
2012-03-07 13:50 EST, Andy Grover
no flags Details

  None (edit)
Description Bruno Goncalves 2012-03-07 03:43:27 EST
Description of problem:
Trying to do iSCSI login to server that has more than 1 target and isnsd running causes the login to fail.

Ex: login to localhost that has 2 targets with 1 LUN each:
iscsiadm -m discoverydb -t isns -p 127.0.0.1 --discover
127.0.0.1:3260,1 iqn.1994-05.com.redhat:tgtd-1
127.0.0.1:3260,1 iqn.1994-05.com.redhat:tgtd-2

iscsiadm -m node -l 
iscsiadm: Could not login to [iface: isns_iface, target: iqn.1994-05.com.redhat:tgtd-1, portal: 127.0.0.1,3260].
iscsiadm: initiator reported error (8 - connection timed out)
iscsiadm: Could not login to [iface: isns_iface, target: iqn.1994-05.com.redhat:tgtd-2, portal: 127.0.0.1,3260].
iscsiadm: initiator reported error (8 - connection timed out)
iscsiadm: Could not log into all portals
Logging in to [iface: isns_iface, target: iqn.1994-05.com.redhat:tgtd-1, portal: 127.0.0.1,3260] (multiple)
Logging in to [iface: isns_iface, target: iqn.1994-05.com.redhat:tgtd-2, portal: 127.0.0.1,3260] (multiple)


Version-Release number of selected component (if applicable):
scsi-target-utils-1.0.14-4.el6.x86_64
isns-utils-0.93-1.0.el6.x86_64
iscsi-initiator-utils-6.2.0.872-34.el6.x86_64
Kernel: 2.6.32-244.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install need packages
yum install iscsi-initiator-utils scsi-target-utils isns-utils

2. Configure tgtd to use isns
at /etc/tgt/targets.conf change isns settings to:
iSNSServerIP 127.0.0.1
iSNSServerPort 3205
#iSNSAccessControl On
iSNS On 

service tgtd start
service isnsd start

3. Create 2 targets with 1 LUN in each
dd if=/dev/zero of=/tmp/disk.RKDijP bs=1M count=0 seek=100
tgtadm --lld iscsi --op new --mode target --tid 1 -T iqn.1994-05.com.redhat:tgtd-1
tgtadm --lld iscsi --op bind --mode target --tid 1 -I ALL
tgtadm --lld iscsi --op new --mode logicalunit --tid 1 --lun 1 -b /tmp/disk.RKDijP

dd if=/dev/zero of=/tmp/disk.xjrB2l bs=1M count=0 seek=100
tgtadm --lld iscsi --op new --mode target --tid 2 -T iqn.1994-05.com.redhat:tgtd-2
tgtadm --lld iscsi --op bind --mode target --tid 2 -I ALL
tgtadm --lld iscsi --op new --mode logicalunit --tid 2 --lun 1 -b /tmp/disk.xjrB2l

4. Discover targets
iscsiadm -m discoverydb -t isns -p 127.0.0.1 --discover

5. Login to targets
iscsiadm -m node -l

---------
It also can be reproduced with automated test:
/mnt/tests/kernel/storage/iscsi/isns-discovery-many-luns

Actual results:
Login fails

Expected results:
Login should work

Additional info:
Comment 1 Andy Grover 2012-03-07 13:50:50 EST
Created attachment 568390 [details]
log from Bruno
Comment 2 RHEL Product and Program Management 2012-05-03 01:44:28 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Jan Kurik 2017-12-06 07:58:07 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.