Bug 800814 - Powertop reports Megawatt battery drain
Powertop reports Megawatt battery drain
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 05:37 EST by Bert DeKnuydt
Modified: 2012-03-17 19:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: powertop-1.98-5.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 14:29:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (1.21 KB, patch)
2012-03-07 11:04 EST, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Bert DeKnuydt 2012-03-07 05:37:34 EST
Description of problem:

Powertop reports absurd numbers for battery discharge rate

Version-Release number of selected component (if applicable):

powertop-1.98-4.fc16.x86_64

The battery reports a discharge rate of 12.6 kW

How reproducible:

Always

Steps to Reproduce:
1. Start powertop
2. 
3.
  
Actual results:

On a Dell Latitude E6520: (w/ Bios A08)

With mains power connected:
     The battery reports a discharge rate of 12.6 kW
With the power adapter unplugged:
     The battery reports a discharge rate of 13.6 MW

Other data from powertop looks plausible.

Expected results:

Either correct numbers, or, when impossible, no numbers at all,
but not something blatantly absurd.

Additional info:
Comment 1 Jaroslav Škarvada 2012-03-07 05:45:05 EST
Please provide output of:
# for d in /sys/class/power_supply/*; do echo $d; cat $d/uevent; done

for both cases.
Comment 2 Bert DeKnuydt 2012-03-07 05:49:55 EST
Wow, that is fast response ...

Here you go:

Connected to mains:

/sys/class/power_supply/AC
POWER_SUPPLY_NAME=AC
POWER_SUPPLY_ONLINE=1
/sys/class/power_supply/BAT0
POWER_SUPPLY_NAME=BAT0
POWER_SUPPLY_STATUS=Full
POWER_SUPPLY_PRESENT=1
POWER_SUPPLY_TECHNOLOGY=Li-ion
POWER_SUPPLY_CYCLE_COUNT=0
POWER_SUPPLY_VOLTAGE_MIN_DESIGN=11100000
POWER_SUPPLY_VOLTAGE_NOW=12523000
POWER_SUPPLY_CURRENT_NOW=1000
POWER_SUPPLY_CHARGE_FULL_DESIGN=7838000
POWER_SUPPLY_CHARGE_FULL=7476000
POWER_SUPPLY_CHARGE_NOW=7838000
POWER_SUPPLY_MODEL_NAME=DELL XV2VV16
POWER_SUPPLY_MANUFACTURER=SMP
POWER_SUPPLY_SERIAL_NUMBER=3208

Disconnected from mains:

POWER_SUPPLY_NAME=AC
POWER_SUPPLY_ONLINE=0
/sys/class/power_supply/BAT0
POWER_SUPPLY_NAME=BAT0
POWER_SUPPLY_STATUS=Discharging
POWER_SUPPLY_PRESENT=1
POWER_SUPPLY_TECHNOLOGY=Li-ion
POWER_SUPPLY_CYCLE_COUNT=0
POWER_SUPPLY_VOLTAGE_MIN_DESIGN=11100000
POWER_SUPPLY_VOLTAGE_NOW=12423000
POWER_SUPPLY_CURRENT_NOW=1260000
POWER_SUPPLY_CHARGE_FULL_DESIGN=7838000
POWER_SUPPLY_CHARGE_FULL=7476000
POWER_SUPPLY_CHARGE_NOW=7240000
POWER_SUPPLY_MODEL_NAME=DELL XV2VV16
POWER_SUPPLY_MANUFACTURER=SMP
POWER_SUPPLY_SERIAL_NUMBER=3208
Comment 3 Jaroslav Škarvada 2012-03-07 09:20:31 EST
Please could you check the following scratch build and let me know if it fixes your problem?
http://koji.fedoraproject.org/koji/taskinfo?taskID=3863861
Comment 4 Bert DeKnuydt 2012-03-07 10:45:36 EST
It reports now:

With mains power connected:
     The battery reports a discharge rate of 12.6 mW
With the power adapter unplugged:
     The battery reports a discharge rate of 13.5 W

So, the same numbers apart from a factor 1e6.  

I guess the issue is solved. Thanks 1e6 :)
Comment 5 Jaroslav Škarvada 2012-03-07 11:02:36 EST
Thanks for info, I will push it.
Comment 6 Jaroslav Škarvada 2012-03-07 11:04:12 EST
Created attachment 568338 [details]
Proposed fix

Proposed fix sent upstream.
Comment 7 Fedora Update System 2012-03-07 11:23:49 EST
powertop-1.98-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/powertop-1.98-5.fc16
Comment 8 Fedora Update System 2012-03-07 11:34:51 EST
powertop-1.98-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/powertop-1.98-6.fc17
Comment 9 Fedora Update System 2012-03-07 17:40:08 EST
Package powertop-1.98-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing powertop-1.98-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3260/powertop-1.98-6.fc17
then log in and leave karma (feedback).
Comment 10 admin 2012-03-08 07:38:27 EST
Yes, update fixes this bug. All seems to be ok.
Comment 11 Fedora Update System 2012-03-13 14:29:36 EDT
powertop-1.98-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-03-17 19:43:19 EDT
powertop-1.98-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.