Bug 800833 - ENOENT while deleting and creating the same file again
ENOENT while deleting and creating the same file again
Status: CLOSED UPSTREAM
Product: GlusterFS
Classification: Community
Component: stat-prefetch (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Raghavendra G
: Reopened
: 800822 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 06:15 EST by Anush Shetty
Modified: 2012-04-27 00:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 00:02:19 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-03-07 06:15:14 EST
Description of problem: On a single export volume with 2 fuse clients, the file created from one client 1 was deleted from client 2. When I tried creating the file with the same name again from Client 1, it returned ENOENT. 

The md-cache timeout value was set to 30. 


Version-Release number of selected component (if applicable): 3.3.0qa25


How reproducible: Consistently


Steps to Reproduce:
1. Client 1: echo 'abcd' > dot
2. Client 2: rm -rf dot
3. Client 1: echo 'abcd' > dot
  
Actual results:
[root@RHEL6 mnt]# echo 'abcd' > dot
-bash: dot: No such file or directory

Additional info:

[2012-03-07 00:18:13.534141] I [fuse-bridge.c:4089:fuse_graph_setup] 0-fuse: switched to graph 0
[2012-03-07 00:18:13.534383] I [fuse-bridge.c:3336:fuse_init] 0-glusterfs-fuse: FUSE inited with protocol versions: glusterfs 7.13 kernel 7.13
[2012-03-07 00:23:34.910871] W [client3_1-fops.c:375:client3_1_open_cbk] 0-dist-client-0: remote operation failed: No such file or directory. Path: /dot
[2012-03-07 00:23:34.910947] W [fuse-bridge.c:692:fuse_fd_cbk] 0-glusterfs-fuse: 78: OPEN() /dot => -1 (No such file or directory)
[2012-03-07 00:23:37.519608] W [client3_1-fops.c:375:client3_1_open_cbk] 0-dist-client-0: remote operation failed: No such file or directory. Path: /dot
[2012-03-07 00:23:37.519653] W [fuse-bridge.c:692:fuse_fd_cbk]
Comment 1 Raghavendra G 2012-03-16 00:07:57 EDT
with non-zero timeouts, its expected that md-cache can go out of sync. In this case, lookup call is served from stale cache (cache rendered stale by unlink of file from another client) there by resulting in ENOENT errors. If some one wants zero tolerance towards stale-caches, they can use timeout value 0. Closing this bug, since its a known issue.
Comment 2 Raghavendra G 2012-03-16 00:25:53 EDT
*** Bug 800822 has been marked as a duplicate of this bug. ***
Comment 3 Anush Shetty 2012-03-29 03:30:41 EDT
Since we see this issue even when md-cache timeout is 0, reopening this bug.
Comment 4 Anush Shetty 2012-04-27 00:02:19 EDT
This issue is not seen anymore.

Note You need to log in before you can comment on or make changes to this bug.