Bug 800834 - Missing library 'yaml' in '/usr/bin/rhc-admin-add-template'
Missing library 'yaml' in '/usr/bin/rhc-admin-add-template'
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Kubernetes (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 06:17 EST by bzhao
Modified: 2015-05-14 21:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 14:23:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bzhao 2012-03-07 06:17:24 EST
Description of problem:
It will prompt the error message: "Invalid descriptor YAML: Requires:" after executing 'rhc-admin-add-template' command to create a template

Version-Release number of selected component (if applicable):
rhc-0.88.1-1.git.1.8333764.el6.noarch

How reproducible:
Always



Steps to Reproduce:
precondition
Create a quickstart template  - /tmp/foo.yaml with wrong packages

---
Vendor: unknown
Requires:
- php-xx
Architecture: noarch
Description:
License: unknown
Subscribes:
  doc-root:
    Required: false
    Type: FILESYSTEM:doc-root
Version: 0.0

1.Add a template
# rhc-admin-add-template -n wordpress -d /tmp/foo.yaml -g git://github.com/openshift/wordpress-example.git -t wordpress  -c 1  -m '{"a":"b"}'

  
Actual results:
It will prompt the error message: "Invalid descriptor YAML: Requires

Expected results:
Template could be created successfully without any error

Additional info:
workaround: add code " require 'yaml' " into /usr/bin/rhc-admin-add-template
Comment 1 Xiaoli Tian 2012-03-09 00:39:06 EST
Move it to ON_QA, since we find the fix should be committed in devenv_1655
Comment 2 bzhao 2012-03-09 03:43:44 EST
Passed verification against devenv 1655

Note You need to log in before you can comment on or make changes to this bug.