Bug 800883 - xorg-x11-xinit-1.3.1-4.fc17.x86_64 should not pull in ConsoleKit-x11
xorg-x11-xinit-1.3.1-4.fc17.x86_64 should not pull in ConsoleKit-x11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 07:55 EST by Lennart Poettering
Modified: 2012-03-23 11:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 11:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2012-03-07 07:55:08 EST
We worked hard to make ConsoleKit unnecessary in Fedora, but now xorg-x11-xinit suddenly started to pull it back in again.

Please drop this dependency from xorg-x11-xinit again
Comment 1 Lennart Poettering 2012-03-07 08:05:50 EST
Note that startx is entirely borked anyway in times where we seal off audit session ids in the kernel. It's no longer possible to spawn off session from other sessions, they can only be spawned from new sessions.
Comment 2 Lennart Poettering 2012-03-07 08:09:22 EST
Also, judging by bug 798686 CK was pulled in again due to some permission problems? Note that since F16 CK is not actually involved in permission management anymore.
Comment 3 Lennart Poettering 2012-03-07 08:12:22 EST
(In reply to comment #1)
> Note that startx is entirely borked anyway in times where we seal off audit
> session ids in the kernel. It's no longer possible to spawn off sessions from
> other sessions, they can only be spawned from new sessions.

uh, i meant "from non-session processes".
Comment 4 Adam Jackson 2012-03-23 11:31:29 EDT
Fixed in -5.

Note You need to log in before you can comment on or make changes to this bug.