Bug 800886 - MoveOrCopyImageGroupCommand fails when passing null in imageDescription parameter of CopyImageVDSCommand
MoveOrCopyImageGroupCommand fails when passing null in imageDescription param...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.1
Assigned To: mkublin
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 08:05 EST by Rami Vaknin
Modified: 2014-01-12 18:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 03:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (87.56 KB, application/x-compressed-tar)
2012-03-07 08:05 EST, Rami Vaknin
no flags Details

  None (edit)
Description Rami Vaknin 2012-03-07 08:05:24 EST
Created attachment 568282 [details]
engine.log

Version:
Devel env, last commit's hash: 17debc7caca685e4e9055d32e896ee3b349974eb

Scenario:
Export template.

Result:
Export fails

2012-03-07 14:38:27,288 INFO  [org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand] (pool-5-thread-398) [66fcfde1] Running command: MoveOrCopyImageGroupCommand internal: true. Entities affected :  ID: dc63baf6-63f1-42f3-a934-4f79ed0d7e4f Type: Storage
2012-03-07 14:38:27,294 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] START, CopyImageVDSCommand(storagePoolId = bebb2832-9abb-4916-a845-faebbb380437, ignoreFailoverLimit = false, compatabilityVersion = 3.0, storageDomainId = 0521b8ec-df61-4c77-ab21-49015a065325, imageGroupId = 4f8d778c-11eb-4d1f-b5c7-51b3d5894634, imageId = c608f51b-4fa1-430b-a920-adafd604848e, dstImageGroupId = 4f8d778c-11eb-4d1f-b5c7-51b3d5894634, vmId = fc8d18ee-aec2-4a6e-b7b7-51446ab24d98, dstImageId = c608f51b-4fa1-430b-a920-adafd604848e, imageDescription = null, dstStorageDomainId = dc63baf6-63f1-42f3-a934-4f79ed0d7e4f, copyVolumeType = SharedVol, volumeFormat = COW, preallocate = Sparse, postZero = false, force = false), log id: aa14859
2012-03-07 14:38:27,294 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] -- CopyImageVDSCommand::ExecuteIrsBrokerCommand: calling 'copyImage' with two new parameters: description and UUID
2012-03-07 14:38:27,294 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] -- copyImage parameters:
2012-03-07 14:38:27,296 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-5-thread-398) [66fcfde1] IrsBroker::Failed::CopyImageVDS due to: XmlRpcExtensionException: Null values aren't supported, if isEnabledForExtensions() == false
2012-03-07 14:38:27,315 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStopVDSCommand] (pool-5-thread-398) [66fcfde1] START, SpmStopVDSCommand(vdsId = c01ca554-62ac-11e1-8105-239da6b2d895, storagePoolId = bebb2832-9abb-4916-a845-faebbb380437), log id: ee23904
2012-03-07 14:38:27,333 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStopVDSCommand] (pool-5-thread-398) [66fcfde1] FINISH, SpmStopVDSCommand, log id: ee23904
2012-03-07 14:38:27,333 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-5-thread-398) [66fcfde1] IRS failover failed - cant allocate vds server
2012-03-07 14:38:27,333 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] FINISH, CopyImageVDSCommand, return: 00000000-0000-0000-0000-000000000000, log id: aa14859
2012-03-07 14:38:27,334 ERROR [org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand] (pool-5-thread-398) [66fcfde1] Command org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand throw Vdc Bll exception. With error message VdcBLLException: java.lang.reflect.UndeclaredThrowableException
2012-03-07 14:38:27,337 ERROR [org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand] (pool-5-thread-398) [66fcfde1] Transaction rolled-back for command: org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand.
Comment 1 mkublin 2012-03-07 09:12:11 EST
http://gerrit.ovirt.org/#change,2626
Comment 2 Itamar Heim 2012-08-09 03:57:01 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.