Bug 800887 - Export template fails and moves the data center to initializing (all storages down)
Export template fails and moves the data center to initializing (all storages...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.1
Assigned To: mkublin
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 08:12 EST by Rami Vaknin
Modified: 2014-01-12 18:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (87.56 KB, application/x-compressed-tar)
2012-03-07 08:12 EST, Rami Vaknin
no flags Details

  None (edit)
Description Rami Vaknin 2012-03-07 08:12:53 EST
Created attachment 568283 [details]
engine.log

Version:
Devel env, last commit's hash: 17debc7caca685e4e9055d32e896ee3b349974eb

Scenario:
Export template. ExportVmTemplateCommand disregards failures in its MoveOrCopyImageGroupCommand child commands

Result:
Export fails


2012-03-07 14:38:27,263 INFO  [org.ovirt.engine.core.bll.ExportVmTemplateCommand] (pool-5-thread-398) [1248568d] Running command: ExportVmTemplateCommand internal: false. Entiti
es affected :  ID: dc63baf6-63f1-42f3-a934-4f79ed0d7e4f Type: Storage
2012-03-07 14:38:27,288 INFO  [org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand] (pool-5-thread-398) [66fcfde1] Running command: MoveOrCopyImageGroupCommand internal: true.
 Entities affected :  ID: dc63baf6-63f1-42f3-a934-4f79ed0d7e4f Type: Storage
2012-03-07 14:38:27,294 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] START, CopyImageVDSCommand(storagePoolId = bebb2832-
9abb-4916-a845-faebbb380437, ignoreFailoverLimit = false, compatabilityVersion = 3.0, storageDomainId = 0521b8ec-df61-4c77-ab21-49015a065325, imageGroupId = 4f8d778c-11eb-4d1f-b
5c7-51b3d5894634, imageId = c608f51b-4fa1-430b-a920-adafd604848e, dstImageGroupId = 4f8d778c-11eb-4d1f-b5c7-51b3d5894634, vmId = fc8d18ee-aec2-4a6e-b7b7-51446ab24d98, dstImageId
 = c608f51b-4fa1-430b-a920-adafd604848e, imageDescription = null, dstStorageDomainId = dc63baf6-63f1-42f3-a934-4f79ed0d7e4f, copyVolumeType = SharedVol, volumeFormat = COW, prea
llocate = Sparse, postZero = false, force = false), log id: aa14859
2012-03-07 14:38:27,294 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] -- CopyImageVDSCommand::ExecuteIrsBrokerCommand: cal
ling 'copyImage' with two new parameters: description and UUID
2012-03-07 14:38:27,294 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] -- copyImage parameters:
                sdUUID=0521b8ec-df61-4c77-ab21-49015a065325
                spUUID=bebb2832-9abb-4916-a845-faebbb380437
                vmGUID=fc8d18ee-aec2-4a6e-b7b7-51446ab24d98
                srcImageGUID=4f8d778c-11eb-4d1f-b5c7-51b3d5894634
                srcVolUUID=c608f51b-4fa1-430b-a920-adafd604848e
                dstImageGUID=4f8d778c-11eb-4d1f-b5c7-51b3d5894634
                dstVolUUID=c608f51b-4fa1-430b-a920-adafd604848e
                descr=null
                
2012-03-07 14:38:27,296 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-5-thread-398) [66fcfde1] IrsBroker::Failed::CopyImageVDS due to: XmlRpcExtension
Exception: Null values aren't supported, if isEnabledForExtensions() == false
2012-03-07 14:38:27,315 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStopVDSCommand] (pool-5-thread-398) [66fcfde1] START, SpmStopVDSCommand(vdsId = c01ca554-62ac-11e1-81
05-239da6b2d895, storagePoolId = bebb2832-9abb-4916-a845-faebbb380437), log id: ee23904
2012-03-07 14:38:27,333 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStopVDSCommand] (pool-5-thread-398) [66fcfde1] FINISH, SpmStopVDSCommand, log id: ee23904
2012-03-07 14:38:27,333 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-5-thread-398) [66fcfde1] IRS failover failed - cant allocate vds server
2012-03-07 14:38:27,333 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.CopyImageVDSCommand] (pool-5-thread-398) [66fcfde1] FINISH, CopyImageVDSCommand, return: 00000000-0000-0
000-0000-000000000000, log id: aa14859
2012-03-07 14:38:27,334 ERROR [org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand] (pool-5-thread-398) [66fcfde1] Command org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand throw Vdc Bll exception. With error message VdcBLLException: java.lang.reflect.UndeclaredThrowableException
2012-03-07 14:38:27,337 ERROR [org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand] (pool-5-thread-398) [66fcfde1] Transaction rolled-back for command: org.ovirt.engine.core.bll.MoveOrCopyImageGroupCommand.
2012-03-07 14:38:28,653 INFO  [org.ovirt.engine.core.bll.storage.SetStoragePoolStatusCommand] (QuartzScheduler_Worker-69) [e937e61] Running command: SetStoragePoolStatusCommand internal: true. Entities affected :  ID: bebb2832-9abb-4916-a845-faebbb380437 Type: StoragePool
2012-03-07 14:38:28,691 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-69) [e937e61] hostFromVds::selectedVds - intg-vdsb.qa.lab.tlv.redhat.com, spmStatus Free, storage pool dc
2012-03-07 14:38:28,698 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (QuartzScheduler_Worker-69) [e937e61] starting spm on vds intg-vdsb.qa.lab.tlv.redhat.com, storage pool dc, prevId -1, LVER 0
2012-03-07 14:38:28,700 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-69) [e937e61] START, SpmStartVDSCommand(vdsId = b5451c38-62ac-11e1-95af-cb24f78bf058, storagePoolId = bebb2832-9abb-4916-a845-faebbb380437, prevId=-1, prevLVER=0, storagePoolFormatType=V2, recoveryMode=Manual, SCSIFencing=false), log id: 2a462354
2012-03-07 14:38:28,725 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-69) [e937e61] spmStart polling started: taskId = 61812a61-946f-420b-bc8b-7bd4274acf5b
2012-03-07 14:40:00,001 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-62) Checking autorecoverable hosts
2012-03-07 14:40:00,004 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-62) Checking autorecoverable hosts done
2012-03-07 14:40:00,004 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-62) Checking autorecoverable storage domains
2012-03-07 14:40:00,005 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-62) Checking autorecoverable storage domains done
2012-03-07 14:40:29,935 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (QuartzScheduler_Worker-69) [e937e61] Failed in HSMGetTaskStatusVDS method
2012-03-07 14:40:29,935 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.BrokerCommandBase] (QuartzScheduler_Worker-69) [e937e61] Error code AcquireLockFailure and error message VDSGenericException: VDSErrorException: Failed to HSMGetTaskStatusVDS, error = Cannot obtain lock
2012-03-07 14:40:29,936 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-69) [e937e61] spmStart polling ended: taskId = 61812a61-946f-420b-bc8b-7bd4274acf5b task status = finished
2012-03-07 14:40:29,936 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-69) [e937e61] Start SPM Task failed - result: cleanSuccess, message: VDSGenericException: VDSErrorException: Failed to HSMGetTaskStatusVDS, error = Cannot obtain lock
2012-03-07 14:40:29,950 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-69) [e937e61] spmStart polling ended. spm status: Free
2012-03-07 14:40:29,954 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMClearTaskVDSCommand] (QuartzScheduler_Worker-69) [e937e61] START, HSMClearTaskVDSCommand(vdsId = b5451c38-62ac-11e1-95af-cb24f78bf058, taskId=61812a61-946f-420b-bc8b-7bd4274acf5b), log id: 46a4b6ec
2012-03-07 14:40:29,967 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMClearTaskVDSCommand] (QuartzScheduler_Worker-69) [e937e61] FINISH, HSMClearTaskVDSCommand, log id: 46a4b6ec
2012-03-07 14:40:29,968 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStartVDSCommand] (QuartzScheduler_Worker-69) [e937e61] FINISH, SpmStartVDSCommand, return: org.ovirt.engine.core.common.businessentities.SpmStatusResult@67e5642f, log id: 2a462354
Comment 1 Moran Goldboim 2012-03-07 08:38:30 EST
Rami, workaround?
Comment 2 mkublin 2012-03-07 09:06:45 EST
http://gerrit.ovirt.org/#change,2626
Comment 3 mkublin 2012-03-07 09:28:48 EST
http://gerrit.ovirt.org/#change,2627

Those two fixes should solve a problem
Comment 4 Rami Vaknin 2012-03-07 10:32:07 EST
(In reply to comment #1)
> Rami, workaround?

I didn't try but probably addition of description to the template before export.
Comment 5 Itamar Heim 2012-08-09 04:05:02 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.