Bug 800933 - CLI subscription-manager list --available should show ServiceLevel field in the displayed results
CLI subscription-manager list --available should show ServiceLevel field in t...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.3
Assigned To: Devan Goodwin
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-07 09:15 EST by Michael Stead
Modified: 2012-06-20 09:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2012-03-07 09:15:53 EST
Description of problem:
CLI subscription-manager list --available needs an additional ServiceLevel field in the displayed results to help the admin user subscribe the system manually to a specific service level.


Expected results:
The service level field should be shown for each subscription returned from 'subscription-manager list --available".
Comment 2 John Sefler 2012-03-07 12:07:46 EST
The subscription-manager list --consumed should also start displaying the ServiceLevel field.
Comment 3 Devan Goodwin 2012-03-16 10:44:40 EDT
Fixed in subscription-manager.git e894676803465c0afcadacd2d4eb7faff170a5e1. Will be in subscription-manager-0.99.11-1
Comment 4 Shwetha Kallesh 2012-03-19 04:54:02 EDT
Moving to verified..

RPM Used:

[root@dhcp201-162 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.99.10-1.git.6.495d07c.el6.x86_64
subscription-manager-gnome-0.99.10-1.git.6.495d07c.el6.x86_64
subscription-manager-migration-data-1.12.2-1.git.0.ede4958.el6.noarch
subscription-manager-0.99.10-1.git.6.495d07c.el6.x86_64


[root@dhcp201-162 ~]# subscription-manager list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+

Product Name:         	Awesome OS Modifier      
Product Id:           	awesomeos-modifier       
Pool Id:              	000000003606853501360685f69f0222
Quantity:             	5                        
Service Level:        	                         
Service Type:        	                         
Multi-Entitlement:    	No                       
Expires:              	03/12/2013               
Machine Type:         	physical                 


[root@dhcp201-162 ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+

Product Name:         	Awesome OS Server Bits   
Contract Number:      	109                      
Account Number:       	12331131231              
Serial Number:        	5059982905477632606      
Active:               	True                     
Quantity Used:        	1                        
Service Level:        	                         
Service Type :        	                         
Begins:               	03/12/2012               
Expires:              	03/12/2013
Comment 6 errata-xmlrpc 2012-06-20 09:06:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.