This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 800999 - Add new --servicelevel option to subscription-manager list --available
Add new --servicelevel option to subscription-manager list --available
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.3
Assigned To: Michael Stead
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-07 09:21 EST by Michael Stead
Modified: 2012-06-20 09:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:06:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2012-03-07 09:21:11 EST
Description of problem:
A --servicelevel option would allow filtering the available subscriptions by SLA.

Expected results:
When using this option, the available subscription list results will be filtered by the SLA provided.

i.e subscription-manager list --available --servicelevel Premium

This will show all available subscriptions with an SLA of 'Premium'
Comment 2 John Sefler 2012-03-07 12:05:24 EST
Note: This new option for the subscription-manager list module should only be used in combination with --available or --consumed (in the same way that --all is tolerated only with --available)
Comment 3 Michael Stead 2012-03-19 14:11:03 EDT
Fix added in commit: a5fa07fffe9d67aa542dbeac503ef56ea7f09006

Will be available in subscription-manager-0.99.11-1+
Comment 4 Shwetha Kallesh 2012-03-20 05:16:50 EDT
Moving to verified.

RPM used:
[root@kvm-guest-04 product]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.99.10-1.git.80.a5fa07f.el6.x86_64
subscription-manager-firstboot-0.99.10-1.git.80.a5fa07f.el6.x86_64
subscription-manager-migration-data-1.12.1.1-1.git.6.ea6813e.el6.noarch
subscription-manager-migration-0.99.10-1.git.80.a5fa07f.el6.x86_64
subscription-manager-0.99.10-1.git.80.a5fa07f.el6.x86_64


[root@kvm-guest-04 product]# subscription-manager list --consumed --servicelevel Premium
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+

Product Name:         	Clustering Bits          
Contract Number:      	7                        
Account Number:       	12331131231              
Serial Number:        	1749805726707093393      
Active:               	True                     
Quantity Used:        	1                        
Service Level:        	Premium                  
Service Type :        	Level 3                  
Begins:               	03/18/2012               
Expires:              	03/18/2013               

Product Name:         	Awesome OS Server Bits   
Contract Number:      	7                        
Account Number:       	12331131231              
Serial Number:        	1749805726707093393      
Active:               	True                     
Quantity Used:        	1                        
Service Level:        	Premium                  
Service Type :        	Level 3                  
Begins:               	03/18/2012               
Expires:              	03/18/2013          



[root@kvm-guest-04 product]# subscription-manager list --available --servicelevel Premium
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+

Product Name:         	Awesome OS Server Bundled
Product Id:           	awesomeos-server         
Pool Id:              	00000000362ac75601362ac820dd0235
Quantity:             	5                        
Service Level:        	Premium                  
Service Type:        	Level 3                  
Multi-Entitlement:    	No                       
Expires:              	03/18/2013               
Machine Type:         	physical
Comment 6 errata-xmlrpc 2012-06-20 09:06:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.