Bug 80101 - accents and cedillas in latin-1 emails not shown in pine
accents and cedillas in latin-1 emails not shown in pine
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-19 18:31 EST by jmatos
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 00:44:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of pine doing what I expect it to do. (28.20 KB, image/png)
2002-12-20 03:53 EST, Mike A. Harris
no flags Details

  None (edit)
Description jmatos 2002-12-19 18:31:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Gnome-terminal is incapable of displaying correctly accents and cedillas in
ISO-8859-1 emails in pine with LANG=en_US.utf-8 (or pt_PT.utf-8 for that
matter). /etc/pine.conf includes ISO-8859-1 as character set default.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Read a ISO-8859-1 email, try including a ISO-8859-1 signature, etc.
    

Expected Results:  Easy alternative should be provided. I have tried xterm,
setting LANG, ISO-8859-15,..., with no luck. Probably my knowledge about LOCALE,
terminals, LANG and other such technicalities is not good enough. Should I have
filed this against gnome-terminal?

Additional info:
Comment 1 Mike A. Harris 2002-12-20 00:44:32 EST
Pine is not unicode compatible, and must be ran in an 8bit encoding, and not
in UTF-8 mode.  To do this run pine with:

LANG=en_US pine

The pine team has been made aware of this inconvenience, however I don't know
if they plan on implementing unicode support as an enhancement or not.

This isn't a bug in pine, rather it is the lack of a feature currently.
Comment 2 jmatos 2002-12-20 03:24:53 EST
I am afraid there is also a gnome-terminal (maybe vte?) limitation.
LANG=en_US pine fails. Compiling powershell 0.9 provided a workaround for me.
Sent you an email to make the point.
Comment 3 Mike A. Harris 2002-12-20 03:43:35 EST
I received your email, attaching it below (please note that bugzilla chokes
on ISO8859-* highbit characters so I have had to remove them completely in
order to paste into this comment or bugzilla will not accept it as bugzilla
is not 8 bit clean either):

==============================================================================
Date: Fri, 20 Dec 2002 08:27:51 +0000 (WET)
From: Joao Palhoto Matos <jmatos@math.ist.utl.pt>
To: mharris@redhat.com
Content-Type: TEXT/PLAIN; charset=ISO-8858-1
Subject: [ISO-8858-1] [Bugzilla 80101] 'LANG=en_US pine' or 'L[ISO-8858-1] ANG=C
pine' fails to display <a with tilde removed>
 
    [ The following text is in the "ISO-8858-1" character set. ]
    [ Your display is set for the "ISO-8859-1" character set.  ]
    [ Some characters may be displayed incorrectly. ]
 
Please try opening pine this email in pine in a gnome-terminal until the
third character in my signature is not a ?
 
This was composed in RH8 but with powershell 0.9.
 
--
Jo<a with tilde removed>o Palhoto Matos                    
http://www.math.ist.utl.pt/~jmatos
Departamento de Matem<a with accent removed>tica
Instituto Superior T<e with accent removed>cnico
Lisboa                                      mailto:jmatos@math.ist.utl.pt
Comment 4 Mike A. Harris 2002-12-20 03:47:30 EST
Now I will attach a screenshot of pine running in konsole with your email
message (the first time I viewed it).
Comment 5 Mike A. Harris 2002-12-20 03:53:42 EST
Created attachment 88829 [details]
Picture of pine doing what I expect it to do.

This attachment is pine 4.44 running in KDE konsole.
Comment 6 Mike A. Harris 2002-12-20 04:00:05 EST
As you can see from the above screenshot, pine shows me your name properly
accented as expected, and worked the first time.

Going over your initial bug report one more time for clarity:

>Gnome-terminal is incapable of displaying correctly accents and cedillas in

This has nothing whatsoever to do with gnome-terminal.

>ISO-8859-1 emails in pine with LANG=en_US.utf-8 (or pt_PT.utf-8 for that
>matter). /etc/pine.conf includes ISO-8859-1 as character set default.

pine does NOT work with UTF-8 period at all.  This is not a bug.  Pine was
not designed for unicode, and does not support it.  In other words, you may
not use pine in a unicode environment because it will not work, having not
been designed to work in a unicode environment.  Therefore you must not
run pine in an en_US.utf-8 locale or any other .utf-8 locale for that matter.

The pine team was informed of this some time ago, and they straight out said
that pine has not been enhanced with the features needed to support unicode,
and that it might at some point in the future, but it does not currently.

So, if one wants to use pine, then one must either use a non UTF-8 encoding
globally, or one must override their LANG variable prior to running pine to
an ISO8859-x locale.

I hope this clarifies the issue further.
Comment 7 Mike A. Harris 2002-12-20 04:05:43 EST
Also, to be clear, I used konsole, whereas you mentioned gnome-terminal.  I'm
happy to make a screenshot of gnome-terminal running pine also if it would
be useful for you to compare with.
Comment 8 jmatos 2002-12-20 18:36:42 EST
Mike A. Harris on 2002-12-20 04:12 said:

> Also, to be clear, I used konsole, whereas you mentioned gnome-terminal.  I'm
> happy to make a screenshot of gnome-terminal running pine also if it would
> be useful for you to compare with.

From your screenshot I doubt you are running RedHat 8.0. Most likely 7.3.
Starting KDE in RH 8.0 and invoking Terminal, Linux Konsole, etc., one gets no
ISO-8859-* character sets. Workarounds involve

LANG=en_US xterm -e pine

or similar but definitely not 

LANG=en_US pine


Note You need to log in before you can comment on or make changes to this bug.