Bug 801089 - Allow accessing environment details with no pools
Allow accessing environment details with no pools
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: beta5
: ---
Assigned To: Tzu-Mainn Chen
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 11:23 EST by Matt Wagner
Modified: 2014-08-17 18:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Wagner 2012-03-07 11:23:59 EST
Description of problem:
Somewhat contradicting https://bugzilla.redhat.com/show_bug.cgi?id=796800 , we want to allow a user to access the environment details page even if there are no pools. Otherwise they have no way of accessing the permissions.

However, creating a new "Component Outline" should still not be permitted from there if there are no pools.
Comment 1 Tzu-Mainn Chen 2012-03-08 16:13:16 EST
Patch created:

https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009478.html
Comment 2 Tzu-Mainn Chen 2012-03-09 10:09:02 EST
Pushed to master:

commit a75b2e42152b9f28353bf853ab35e7585b66d51e
BZ 801089 always allow user to click through to pool_family details
Comment 4 wes hayutin 2012-03-30 14:57:42 EDT
assigning to rehana
Comment 5 Rehana 2012-04-03 07:28:54 EDT
User is allowed to view the "Cloud" details page even if there are no cloud resource zone created.Also observed that there is no "Import Image" and "New image" button in the detail page.

verified on ;

 rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 6 errata-xmlrpc 2012-05-15 18:49:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.