Bug 801107 - Katello generates invalid RHEL5 system templates
Katello generates invalid RHEL5 system templates
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 12:06 EST by James Laska
Modified: 2014-09-18 11:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-03-07 12:06:50 EST
Description of problem:

Katello generates invalid system templates for RHEL-5.

Version-Release number of selected component (if applicable):
 * candlepin-0.5.23-1.el6.src.rpm
 * katello-0.1.301-2.el6.src.rpm
 * katello-candlepin-cert-key-pair-1.0-1.src.rpm
 * katello-certs-tools-1.0.3-1.el6.src.rpm
 * katello-cli-0.1.100-2.el6.src.rpm
 * katello-configure-0.1.101-1.el6.src.rpm
 * katello-qpid-broker-key-pair-1.0-1.src.rpm
 * katello-qpid-client-key-pair-1.0-1.src.rpm
 * katello-selinux-0.1.8-1.el6.src.rpm
 * pulp-1.0.0-4.el6.src.rpm


How reproducible:
 * incorrect every time

Steps to Reproduce:
1. Export a system template for RHEL5 repository/distro

<name>rhel-x86_64-server-5-cf-tools</name>
<os>
    <name>Red Hat Enterprise Linux Server</name>
    <version>5.8</version>
    <arch>x86_64</arch>
    <install type="url">
        <url>http://flatline-katello.usersys.redhat.com/pulp/ks/redhat/Stage/content/dist/rhel/server/5/5Server/x86_64/os/ </url>
    </install>
    <rootpw>redhat</rootpw>
</os>

Expected results:

<name>rhel-x86_64-server-5-cf-tools </name>
<os>
    <name>RHEL-5</name>
    <version>U8</version>
    <arch>x86_64</arch>
    <install type="url">
        <url>http://flatline-katello.usersys.redhat.com/pulp/ks/redhat/Stage/content/dist/rhel/server/5/5Server/x86_64/os/</url>
    </install>
    <rootpw>redhat</rootpw>
</os>


Additional info:

 * The workaround is straightforward, but hand-editing the system template shouldn't be required by customers
Comment 2 Ivan Necas 2012-03-09 09:01:51 EST
Fixed in commit 08d71273d30e2e63e75062da94019e9ecb274ec9. This commit allows using '*' as wildcard in /etc/katello/mapping.yum. So line

   "Red Hat Enterprise Linux* 5.8": [RHEL-5, U8]

will work for "Red Hat Enterprise Linux 5.8", "Red Hat Enterprise Linux Server 5.8" and  "Red Hat Enterprise Linux Workstation 5.8" if needed.

Also the mapping file was modified to handle this possibility.

To enable it without this commit, adding line like this to /etc/katello/mapping.yml should work as well:

   "Red Hat Enterprise Linux Server 5.8": [RHEL-5, U8]
Comment 3 Ivan Necas 2012-03-09 10:56:51 EST
Also made /etc/katello/mapping.yum file optional (not fail if it doesn't exists, it's not needed for unit tests for example) b178f467ba0617507f587269c487a1e2565b3b0e
Comment 7 Kedar Bidarkar 2012-03-16 06:50:36 EDT
[kbidarka@dhcp193-96 Desktop]$ xmllint --format --recover ./Devc\ Template-Library-export.xml 
<?xml version="1.0" encoding="UTF-8"?>
<template>
  <name>Devc Template</name>
  <os>
    <name>RHEL-5</name>
    <version>U8</version>
    <arch>x86_64</arch>
    <install type="url">
      <url>http://scalpel.lab.eng.pnq.redhat.com/pulp/ks/ACME_Corporation/Library/content/dist/rhel/server/5/5.8/x86_64/os/</url>
    </install>



[root@scalpel entitlement]# rpm -qav | grep -i katello 
katello-glue-candlepin-0.1.304-1.el6.noarch
katello-configure-0.1.104-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-pulp-0.1.304-1.el6.noarch
katello-selinux-0.1.8-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-0.1.104-1.el6.noarch
katello-common-0.1.304-1.el6.noarch
katello-0.1.304-1.el6.noarch
katello-all-0.1.304-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-0.1.104-1.el6.noarch
katello-glue-foreman-0.1.304-1.el6.noarch
katello-certs-tools-1.0.4-1.el6.noarch
Comment 8 errata-xmlrpc 2012-05-15 14:56:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html
Comment 9 Mike McCune 2013-08-16 13:51:50 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.