This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 801199 - component outline rebuild all (latest) build issue
component outline rebuild all (latest) build issue
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
medium Severity high
: beta5
: ---
Assigned To: Imre Farkas
wes hayutin
: Triaged
Depends On:
Blocks: 802665
  Show dependency treegraph
 
Reported: 2012-03-07 17:16 EST by Dave Johnson
Modified: 2016-09-20 01:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:51:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-03-07 17:16:09 EST
Description of problem:
============================
If you rebuild a component outline that has images built/pushed, the new build never transitions to become the (latest) if one of the targetimage builds experiences a failure.  

On top of that, this new build cannot be pushed to any of the providers, the push buttons are not displaying even for the targetimages that were successfully built.

This only occurs when one of the targetimage builds has a failure.  If all targetimage builds succeed, everything works correctly (latest builds gets latest tag as well as push button)

This means instead of addressing the single failure, everything has to be rebuilt again.


Version-Release number of selected component (if applicable):
=================================================================
aeolus-all-0.8.0-41.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
aeolus-conductor-doc-0.8.0-41.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
rubygem-aeolus-cli-0.3.0-13.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch

How reproducible:
==================
100%

Steps to Reproduce:
=========================
1.  configure for all providers, mock,ec2,rhevm,vsphere
2.  create a component outline 
3.  build it
4.  push it
5.  on the component outline detail page, rebuild all
6.  using virt-manager, stop one of the libvirt builds for either rhevm or vsphere (to simulate failure)
7.  notice that after the builds complete, this new build never becomes the "latest" (because of the single build error)
8.  also notice, no push/upload buttons on the provider images
Comment 1 Imre Farkas 2012-03-13 08:52:05 EDT
Patch has been posted: https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009548.html
Comment 2 Imre Farkas 2012-03-13 12:02:07 EDT
This issue has been fixed. Please verify the commit 352949c78676492f15a41d62a9b47cbee4b48904
Comment 4 Dave Johnson 2012-03-16 11:26:21 EDT
This looks a lot better, good to go with the following rpms which is verified in a puddle, just not sure if it is a official puddle for beta5.  Holding off until closer to the beta 5 release

[root@gs-bl460cg1-01 ~]# rpm -qa | grep aeolus | sort
aeolus-all-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 5 errata-xmlrpc 2012-05-15 18:51:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.