Bug 80120 - gnome-terminal not displaying Japanese characters at all
Summary: gnome-terminal not displaying Japanese characters at all
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vte (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-20 07:59 UTC by Jens Petersen
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 02:21:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2002-12-20 07:59:31 UTC
Description of problem:
The current gnome-terminal is displaying Japanese characters at all
in a Japanese locale.  Whitespace appears instead.

Version-Release number of selected component (if applicable):
gnome-terminal-2.1.3-2
vte-0.10.7-2

How reproducible:
Every time.

Steps to Reproduce:
Start a new gnome-terminal session in ja locale
  % killall -9 gnome-terminal
  % LANG=ja_JP gnome-terminal
  % date
    
Actual results:
2002   12   20          16:55:13 JST

Expected results:
2002<nen> 12<gatu> 20<nichi> <kinyoubi> 16:55:13 JST
where the words in <>'s represent kanji

Additional info:
Has been working until quite recently.
Korean and Chinese seem to be ok.

Comment 1 Havoc Pennington 2002-12-20 14:49:49 UTC
Please, file all terminal emulation/behavior bugs against vte, 
gnome-terminal is just the menus and dialogs and command line options.

Comment 2 Akira TAGOH 2002-12-24 07:28:56 UTC
It works for me. I've installed it with freshly Everything install from
Phoebe-re1220.Beta3-RC3.

Comment 3 Leon Ho 2002-12-27 02:24:34 UTC
A bit strange. I got a desktop install and it couldn't display. FC_DEBUG=1 
shows that it uses Luxi Mono. Actually look like fontconfig font matching has 
changed. Has the latest update changes anything on that?

Comment 4 Jens Petersen 2003-01-21 02:21:29 UTC
I think this was actually due to fontconfig problems that
got fixed in Phoebe beta2.


Note You need to log in before you can comment on or make changes to this bug.